Bug 74631 - kernel doesn't compile because $LANG
kernel doesn't compile because $LANG
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 20:07 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 14:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-27 20:07:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
on rh 8.0 (i suppose before also)

because of line 277 of the Makefile in the kernel source:
"kbuild_2_11_nostdinc    := -nostdinc $(shell $(CC) -print-search-dirs | sed -ne
's/install: \(.*\)/-I \1include/gp')"


when $LANG is set to fr_FR for example

gcc -print-search-dirs results:
4]# gcc -print-search-dirs
installis: /usr/lib/gcc-lib/i386-redhat-linux/3.2/
programmes: =/usr/lib/gcc-lib/i386


installis: != install:
 so included dirs aren't there and it doesn't compile


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd /usr/src/linux-2.4.18-14
2.put a .config there
3.make dep bzImage    on a fr_FR system

	

Additional info:
Comment 1 Alan Cox 2002-10-08 17:36:37 EDT
This has been fixed in the base kernel tree by forcing LANG=C on that command

Note You need to log in before you can comment on or make changes to this bug.