Bug 746364 - Dell Vostro 1015 touchpad not recognised as touchpad but works as mouse
Dell Vostro 1015 touchpad not recognised as touchpad but works as mouse
Status: CLOSED DUPLICATE of bug 590880
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-14 18:54 EDT by Mads Kiilerich
Modified: 2011-10-17 20:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 20:10:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (80.44 KB, application/octet-stream)
2011-10-14 18:54 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2011-10-14 18:54:03 EDT
Created attachment 528284 [details]
dmesg

The touchpad in Dell Vostro 1015 doesn't have touchpad features such as scrolling to the right of the pad. X doesn't use the synaptics driver but see it as "PS/2 Generic Mouse", probably because "/lib/udev/input_id /class/input/event4" says "ID_INPUT=1 ID_INPUT_MOUSE=1", probably because of how the kernel detects it.

dmesg:

[    1.252173] i8042: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    1.268797] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.268804] serio: i8042 AUX port at 0x60,0x64 irq 12
[    1.268894] mousedev: PS/2 mouse device common for all mice

[    2.251704] usb 4-1: New USB device found, idVendor=0cf3, idProduct=3002
[    2.251709] usb 4-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.286942] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input4

/proc/bus/input/devices:
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input4
U: Uniq=
H: Handlers=mouse0 event4 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

evtest:
Input driver version is 1.0.1
Input device ID: bus 0x11 vendor 0x2 product 0x1 version 0x0
Input device name: "PS/2 Generic Mouse"
Supported events:
  Event type 0 (EV_SYN)
  Event type 1 (EV_KEY)
    Event code 272 (BTN_LEFT)
    Event code 273 (BTN_RIGHT)
    Event code 274 (BTN_MIDDLE)
  Event type 2 (EV_REL)
    Event code 0 (REL_X)
    Event code 1 (REL_Y)

I would expect that the kernel somehow detected it as a synaptics device.

kernel-PAE-2.6.40.6-0.fc15.i686, but same problem seen with 3.1 rc8.
Comment 1 Josh Boyer 2011-10-17 20:10:16 EDT
This has an ALPS touchpad.  There's an open bug for tracking the driver as it gets worked on upstream.

*** This bug has been marked as a duplicate of bug 590880 ***

Note You need to log in before you can comment on or make changes to this bug.