Bug 746371 - df shows tmpfs /run twice
df shows tmpfs /run twice
Status: CLOSED DUPLICATE of bug 709351
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-14 22:30 EDT by Brad Scalio
Modified: 2011-10-15 02:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-15 02:00:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Scalio 2011-10-14 22:30:15 EDT
Description of problem:
df shows tmpfs /run listed twice.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. issue a `df`

  
Actual results:
[root@melkweg var]# df
Filesystem                 1K-blocks     Used Available Use% Mounted on
rootfs                      35380904  3848368  31173196  11% /
devtmpfs                     1931968        0   1931968   0% /dev
tmpfs                        1941976      160   1941816   1% /dev/shm
tmpfs                        1941976    47536   1894440   3% /run
/dev/mapper/vg00-lvol_root  35380904  3848368  31173196  11% /
tmpfs                        1941976    47536   1894440   3% /run
tmpfs                        1941976        0   1941976   0% /sys/fs/cgroup
tmpfs                        1941976        0   1941976   0% /media
/dev/sda1                     495844    58789    411455  13% /boot
/dev/mapper/vg00-lvol_var   15126920   762776  13595736   6% /var
/dev/mapper/vg00-lvol_home 100791728 63077376  32594352  66% /home

Expected results:
[root@melkweg var]# df
Filesystem                 1K-blocks     Used Available Use% Mounted on
rootfs                      35380904  3848368  31173196  11% /
devtmpfs                     1931968        0   1931968   0% /dev
tmpfs                        1941976      160   1941816   1% /dev/shm
tmpfs                        1941976    47536   1894440   3% /run
/dev/mapper/vg00-lvol_root  35380904  3848368  31173196  11% /
tmpfs                        1941976        0   1941976   0% /sys/fs/cgroup
tmpfs                        1941976        0   1941976   0% /media
/dev/sda1                     495844    58789    411455  13% /boot
/dev/mapper/vg00-lvol_var   15126920   762776  13595736   6% /var
/dev/mapper/vg00-lvol_home 100791728 63077376  32594352  66% /home

Additional info:

Not sure if it's due to the link for /var/run and /var/lock -> /var/run/local but similarly to how a bound mount doesn't show up in the df but in /proc/mounts it really shouldn't show up twice
Comment 1 Ondrej Vasik 2011-10-15 02:00:29 EDT
Thanks for report, already reported - closing duplicate. This was already discussed upstream, some workarounds were suggested (changing default MOUNT file in lib/mountlist.c) but afaik no real solution chosen ...

*** This bug has been marked as a duplicate of bug 709351 ***

Note You need to log in before you can comment on or make changes to this bug.