Bug 746386 - id/groups command display only primary groups of user
id/groups command display only primary groups of user
Status: CLOSED DUPLICATE of bug 745675
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-15 04:59 EDT by Francesco
Modified: 2011-10-15 08:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-15 08:37:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Francesco 2011-10-15 04:59:39 EDT
Description of problem:
groups command non display secondary groups of user

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. su -
2. groupadd test
3. getent group test (output is OK)
4. cat /etc/group | grep test (output is OK)
5. gpasswd -a fdaluisio test
  
Actual results:
after point 5

6. cat /etc/group | grep test (output is OK, fdaluisio is in test group)
7. logout fdaluisio e relogin X session
8. id -Gn fdaluisio (show only fdaluisio group)
9. groups fdaluisio (show only fdaluisio group)


Expected results:
id -Gn fdaluisio 
fdaluisio test 

id/groups commands must show primary and secondary groups for fdaluisio user

Additional info:
With F15 uptodate this doesn't happen

rpm -qa "coreutils*"
coreutils-libs-8.12-2.fc16.x86_64
coreutils-8.12-2.fc16.x86_64

rpm -qa "shadow-utils*"
shadow-utils-4.1.4.3-7.fc16.x86_64

selinux enabled
F16-rawhide is uptodate at date file this bug
Comment 1 Ondrej Vasik 2011-10-15 08:37:43 EDT

*** This bug has been marked as a duplicate of bug 745675 ***

Note You need to log in before you can comment on or make changes to this bug.