Bug 746426 - RFE: rhel5 Xen pygrub: support GPT partitioned domU disks (Fedora 16 default)
RFE: rhel5 Xen pygrub: support GPT partitioned domU disks (Fedora 16 default)
Status: CLOSED DUPLICATE of bug 746602
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-15 12:58 EDT by Pasi Karkkainen
Modified: 2011-10-17 04:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 04:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pasi Karkkainen 2011-10-15 12:58:13 EDT
Description of problem:
Fedora 16 uses GPT partition table as a default on all new installs. RHEL5 Xen pygrub does not seem to work with GPT disks. I tested with F16 final TC1 PV domU. 

GPT patch for upstream Xen pygrub is available for F16 Xen 4.1.1 in here:
https://bugzilla.redhat.com/show_bug.cgi?id=745335

Version-Release number of selected component (if applicable):
RHEL 5.7 Xen pygrub.

How reproducible:
Always.

Steps to Reproduce:
1. Install RHEL 5.7 Xen dom0.
2. Use virt-install to install F16 final TC1 or later PV domU.
3. virt-install -d -n f16test32 -r 1024 --vcpus=2 -f /dev/VolGroup00/f16test32 --vnc -p -l "http://server.tld/fedora/mount-f16-final-tc1-i386-iso/"
  
Actual results:
F16 domU installation works OK, but after reboot the domU fails to start due to pygrub error:

ERROR    POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: Boot loader didn't return any data!")

Expected results:
F16 PV domUs with GPT partitioned disks can be booted.

Additional info:

Note that F16 alpha/beta have other bugs that prevent installation as PV domU. F16 final TC1 and later versions do work OK as Xen PV domU.

output from virt-install:

Guest installation complete... restarting guest.
Sat, 15 Oct 2011 19:47:23 ERROR    POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: Boot loader didn't return any data!")
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start f16test32'; otherwise, please
 restart your installation.
Sat, 15 Oct 2011 19:47:23 ERROR    POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: Boot loader didn't return any data!")
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 895, in ?
    main()
  File "/usr/sbin/virt-install", line 777, in main
    dom.create()
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: Boot loader didn't return any data!")
Comment 1 Pasi Karkkainen 2011-10-15 13:00:30 EDT
Also there's a workaround available in F16 final TC1 and later versions. You can pass "nogpt" boot option for the F16 anaconda installer, which forces creation of old-style MSDOS partition tables instead of new GPT.
Comment 2 Paolo Bonzini 2011-10-17 04:43:42 EDT

*** This bug has been marked as a duplicate of bug 746602 ***

Note You need to log in before you can comment on or make changes to this bug.