Bug 74644 - perl pipe gaves problems
perl pipe gaves problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-28 17:47 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-28 03:07:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
perl script that proves the perl problem, this appeared on redhat limbo, null, and is on rh 8.0 (works with rh 7.x) (1.50 KB, text/plain)
2002-09-28 17:49 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-09-28 17:47:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
when using non-blocking perl-pipe, it only receives the first line, this gives
problems with dvd::rip

Perl example is furnished.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.check the perl script, or install dvd::rip (+transcode)
2.run perl script (or in dvdrip use the "read toc of dvd")

	

Actual Results:  Only the first "line" is returned

Expected Results:  should return all lines in the variable

Additional info:
Comment 1 Need Real Name 2002-09-28 17:49:51 EDT
Created attachment 77604 [details]
perl script that proves the perl problem, this appeared on redhat limbo, null, and is on rh 8.0  (works with rh 7.x)
Comment 2 Warren Togami 2005-05-28 03:07:30 EDT
Closing due to lack of activity and likely fixed in modern perl.  If this is
still an issue in RHEL4, FC3 or FC4 please open a new bug with new test
information and exact versions of packages.

Note You need to log in before you can comment on or make changes to this bug.