Bug 746450 - Auto mounted nfs4 home directories have wrong owner and group.
Auto mounted nfs4 home directories have wrong owner and group.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-15 22:35 EDT by David Highley
Modified: 2011-11-19 22:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-19 22:08:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Highley 2011-10-15 22:35:06 EDT
Description of problem:
Auto mounted nfs4 home directories have wrong owner and group.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.5-1.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Use NIS and autofs to mount home directories. The comments in the /etc/idmap.conf file indicate that it should default to the domain of the host. We have had to force it to the domain by defining it since Fedora 14 otherwise it would mount with owner and group of nobody. Now with this release it has some strange numbers of, ls -l:
drwxr-x---. 130 4294967294 4294967294 8192 Oct 15 19:13 dhighley

Which fouls up everything. So far no work around has been discovered.
Comment 1 David Highley 2011-10-15 23:02:18 EDT
Can confirm downgrade to version nfs-utils-1.2.5-0.fc16.x86_64 fixes the ownership issue for the auto mounted directories.
Comment 2 Steve Dickson 2011-11-14 16:21:43 EST
I wonder if this is the same problem as:
    https://bugzilla.redhat.com/show_bug.cgi?id=746497
Comment 3 David Highley 2011-11-15 23:17:40 EST
Sorry for the late reply. We read the other bug report and it is possible they are one in the same. But we are not sure given the description. Our experience is we have had to modify the map file since the Fedora 14 release adding the domain which the comments in the file indicate we should not need to do. After version 1.2.5-1 was installed we had to down grade to get the mapping permissions to work right at all.

The other report indicates there is a version 1.2.5-3 which we do not see in the repository or the updates-testing repository which may fix the issue.
Comment 4 Steve Dickson 2011-11-18 11:20:04 EST
(In reply to comment #3)
> Sorry for the late reply. We read the other bug report and it is possible they
> are one in the same. But we are not sure given the description. Our experience
> is we have had to modify the map file since the Fedora 14 release adding the
> domain which the comments in the file indicate we should not need to do. After
> version 1.2.5-1 was installed we had to down grade to get the mapping
> permissions to work right at all.
> 
> The other report indicates there is a version 1.2.5-3 which we do not see in
> the repository or the updates-testing repository which may fix the issue.
Here is the build (1.2.5-3) that is making it through the release process
   http://koji.fedoraproject.org/koji/buildinfo?buildID=274080

Please give it a try to see if it resolves the problem...
Comment 5 David Highley 2011-11-19 22:08:04 EST
Tested with version 1.2.5-3 and the issue is fixed, that version is now released so we are closing the report.

Note You need to log in before you can comment on or make changes to this bug.