Bug 746503 - Impossible to turn off a VM
Impossible to turn off a VM
Status: CLOSED DUPLICATE of bug 746007
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
x86_64 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-16 12:50 EDT by Dario Faggioli
Modified: 2012-06-07 15:40 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 15:40:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dario Faggioli 2011-10-16 12:50:36 EDT
I can't turn off a VM via "Virtual Machine Manager". As I click on either "Shut Down" or "Force  Off" the virtual console closes, but the domain is still listed as running in the main window. OTOH, here's what `xm list' and `xl list' think about that (domain name is Debian-HVM):

# xm list
Name                                        ID   Mem VCPUs      State   Time(s)
Debian-HVM                                      2048     2                 0.0
Domain-0

# xl list
Name                                        ID   Mem VCPUs	State	Time(s)
Domain-0

Also, any subsequent attempt of rebooting, pausing or starting again the same domain fails.
  
Here's what VMM says:

Error shutting down domain: failed Xen syscall  ioctl 3166208

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 44, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 65, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1094, in destroy
    self._backend.destroy()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 553, in destroy
    if ret == -1: raise libvirtError ('virDomainDestroy() failed', dom=self)
libvirtError: failed Xen syscall  ioctl 3166208

Here's the info about versions of xen* and libvirt* related packages:
# rpm -qa | grep xen
xen-4.1.1-6.fc16.x86_64
netxen-firmware-4.0.534-4.fc15.noarch
xen-libs-4.1.1-6.fc16.x86_64
xen-hypervisor-4.1.1-6.fc16.x86_64
xen-runtime-4.1.1-6.fc16.x86_64
xen-doc-4.1.1-6.fc16.x86_64
xen-licenses-4.1.1-6.fc16.x86_64

# rpm -qa | grep libvirt
libvirt-client-0.9.6-2.fc16.x86_64
libvirt-python-0.9.6-2.fc16.x86_64
libvirt-0.9.6-2.fc16.x86_64
Comment 1 Dario Faggioli 2011-10-17 05:25:23 EDT
As a side note, if I create a VM manually via `xm create', I seem then to be able to turn off/destroy it without any problem:

# xm create -c /etc/xen/xmexample.hvm
Using config file "/etc/xen/xmexample.hvm".
Started domain ExampleHVMDomain (id=10)

# xm list
Name                                        ID   Mem VCPUs      State   Time(s)
Debian-HVM                                      2048     2                 0.0
Domain-0                                     0  6881     8     r-----   2261.7
ExampleHVMDomain                            10   128     1     -b----      1.9

# xm shutdown 10
# xm list
Name                                        ID   Mem VCPUs      State   Time(s)
Debian-HVM                                      2048     2                 0.0
Domain-0                                     0  6881     8     r-----   2265.8

I also noticed this morning xen packages have been updated, but the issue is still there.

# rpm -qa | grep xen
netxen-firmware-4.0.534-4.fc15.noarch
xen-libs-4.1.1-8.fc16.x86_64
xen-4.1.1-8.fc16.x86_64
xen-doc-4.1.1-8.fc16.x86_64
xen-hypervisor-4.1.1-8.fc16.x86_64
xen-licenses-4.1.1-8.fc16.x86_64
xen-runtime-4.1.1-8.fc16.x86_64
Comment 2 Fedora Admin XMLRPC Client 2011-11-30 14:32:53 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-11-30 14:36:30 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 14:44:00 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 14:54:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Cole Robinson 2012-06-07 15:40:14 EDT

*** This bug has been marked as a duplicate of bug 746007 ***

Note You need to log in before you can comment on or make changes to this bug.