Bug 74654 - Add "null" storage module request
Summary: Add "null" storage module request
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-29 19:21 UTC by Philip Rowlands
Modified: 2007-03-27 03:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 12:18:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Philip Rowlands 2002-09-29 19:21:26 UTC
Please consider compiling in "null" storage module support. This is done by 
passing --enable-storeio="aufs,coss,diskd,null,ufs" to configure.

null allows the user to configure no disk caching at all, which is useful when 
squid's other features (proxying, logging) but not caching are required in a 
DMZ environment.

Comment 1 Bill Nottingham 2003-01-15 20:57:07 UTC
should be done in 2.5.STABLE1-1.

Comment 2 Philip Rowlands 2003-01-24 23:13:05 UTC
Sorry, I can't see the fix. From squid-2.5.STABLE1-1.src.rpm, dated Jan 16 2003, squid.spec still uses --enable-storeio="aufs,coss,diskd,ufs".

Comment 3 Jay Fenlason 2003-01-29 16:12:02 UTC
I put up squid-2.5.STABLE1-3.i386.rpm and squid-2.5.STABLE1-3.src.rpm on
ftp://people.redhat.com/fenlason/  The binary was built on 8.0 because I don't
have any 7.3 systems to hand.  It has two changes: one is the null storage
module, another is a tweak to the number of maximum file descriptors it can
open.  If you can check it out, I'll see if I can slip it into the next beta. 
It may be too late, though.



Note You need to log in before you can comment on or make changes to this bug.