Bug 746605 - ValueError: list.remove(x): x not in list
ValueError: list.remove(x): x not in list
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:5d830504d0fc4de8b879d8b9a0e...
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-17 04:52 EDT by Hongqing Yang
Modified: 2011-10-20 00:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-16.22-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 00:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-u1bWrm (240.71 KB, text/plain)
2011-10-17 04:53 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2011-10-17 04:52:56 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc9.git0.0.fc16.i686
product:        Fedora
reason:         ValueError: list.remove(x): x not in list
time:           Mon Oct 17 04:55:09 2011
version:        16-TC1

anaconda-tb-u1bWrm: Text file, 246491 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.21 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 442, in cancelAction
:    self._actions.remove(action)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/autopart_type.py", line 175, in getNext
:    self.storage.devicetree.cancelAction(action)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1197, in nextClicked
:    rc = self.currentWindow.getNext ()
:ValueError: list.remove(x): x not in list
Comment 1 Hongqing Yang 2011-10-17 04:53:01 EDT
Created attachment 528489 [details]
File: anaconda-tb-u1bWrm
Comment 2 David Lehman 2011-10-18 13:01:55 EDT
This is caused by a typo in a patch of mine. I think it prevents the autopart shrink option from working at all. I have a patch already.
Comment 3 Fedora Update System 2011-10-19 14:43:50 EDT
anaconda-16.22-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.22-1.fc16
Comment 4 Fedora Update System 2011-10-19 22:25:30 EDT
Package anaconda-16.22-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.22-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14624
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-10-20 00:03:57 EDT
anaconda-16.22-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.