Bug 74661 - mangled sendmail capabilities with upgraded installation
Summary: mangled sendmail capabilities with upgraded installation
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: postfix   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-30 02:51 UTC by opus6
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-13 20:50:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description opus6 2002-09-30 02:51:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:
On a system with a working postfix-1.1.5, upgrading produced the following problems:
a) removed existing postfix sendmail command;  installed sendmail.postfix but
failed to either rename it or build a link in /usr/sbin;  manually creating a
symbolic link between sendmail.postfix and the target sendmail restores outgoing
mail flow.

b) removed daily reporting tools 1postfix and pflogsumm.pl




Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Didn't attempt to reproduce because of need to get system back in operation.

Comment 1 John Dennis 2003-06-13 20:50:38 UTC
This bug was reported against an obsolete rpm which I'm not familar with. The
first problem sounds like /usr/sbin/alternatives was not invoked in %post. I've
tested the current spec file and it seems to handle the links correctly. I'm
sorry it deleted a file, the next postfix rpm (2.0.11) has removed all "rm"
commands and rpm itself should never touch a file not listed in the %files
section of the spec file. I don't think these problems are going to come up
again and given the age of  this bug I think I'm going to close it.


Note You need to log in before you can comment on or make changes to this bug.