This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 746629 - nss: select client certificates by DER
nss: select client certificates by DER
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: curl (Show other bugs)
6.2
All Linux
high Severity high
: rc
: ---
Assigned To: Kamil Dudka
Jiri Pospisil
: Patch
Depends On: 733685 733657 734760 746632 754771 768669 806058
Blocks: 836160
  Show dependency treegraph
 
Reported: 2011-10-17 06:39 EDT by Kamil Dudka
Modified: 2013-07-04 04:13 EDT (History)
7 users (show)

See Also:
Fixed In Version: curl-7.19.7-30.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 733657
Environment:
Last Closed: 2013-02-21 05:09:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Dudka 2011-10-17 06:39:37 EDT
+++ This bug was initially created as a clone of Bug #733657 +++

Description of problem:
File base names are not globally unique.  Their collisions cause us problems.


Version-Release number of selected component (if applicable):
curl-7.21.7-4.fc17


Steps to Reproduce:
1. load two client certificates from file with the same file base names


Actual results:
nickname collision


Additional info:
The same problem occurs when the contents of a file is changed meanwhile.

--- Additional comment from emaldona on 2011-09-12 19:59:10 CEST ---

Comment on attachment 521708 [details]
[PATCH 4/4] nss: avoid a SIGSEGV with immature version of NSS

ok until 733685 gets fixed.

--- Additional comment from kdudka on 2011-09-14 12:56:52 CEST ---

patches sent upstream:

http://thread.gmane.org/gmane.comp.web.curl.library/32984

--- Additional comment from kdudka on 2011-09-19 14:42:47 CEST ---

fixed in curl-7.22.0-2.fc17

--- Additional comment from kdudka on 2011-10-17 12:29:00 CEST ---

pushed upstream:

https://github.com/bagder/curl/compare/d47d95ac3b...491c5a497c
Comment 2 Suzanne Yeghiayan 2012-02-14 18:17:51 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 RHEL Product and Program Management 2012-09-12 08:41:16 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 22 Jiri Pospisil 2013-01-17 08:05:14 EST
Reproduced in 7.19.7-26.el6_2.4 and verified in 7.19.7-35.el6.
Comment 25 errata-xmlrpc 2013-02-21 05:09:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0393.html

Note You need to log in before you can comment on or make changes to this bug.