Bug 74663 - RPM erase of glibc erased many linux commands
RPM erase of glibc erased many linux commands
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-30 02:35 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-30 02:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-30 02:35:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
My linux system crashed -- perhaps because of a hardware problem -- deleting and
corrupting files.  After I got the system working again, I found evidence that
something was wrong with the glibc files.  up2date did not help because I had
the latest versions of these files.  So I decided to erase these files using
"rpm -e --nodeps" with the intent of reloading them.  But this command did not
merely erase the related rpm files; it also erased about three-quarters of the
/usr/bin directory, all the /sbin directory, and I don't know what else. 
Commands like ls and, more importantly, init no longer worked.  I couldn't even
halt the system.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

About once every ten days or so, my computer freezes up, forcing me to use the
computer reset button.  I suspect a hardware problem because there is no pattern
to the freezing.  But the bug that I am reporting did not freeze the computer;
rather, it deleted common commands.  I've saved the bad root file system but do
not see why it would contain any relevant information.  

I can't exclude the possibility that the original crash did something that
allowed all these files to be erased when I used rpm.

If this bug is not unique to my system, then I suggest that something be added
to the rpm code to prevent people from doing what I did.  The catastrophic
consequences were not obvious.
Comment 1 Jeff Johnson 2002-10-04 16:26:49 EDT
Erasing glibc with --nodeps removed an
essential shared library. You will need
to re-install glibc, probably by boot in
rescue mode and installing glibc packages
with rpm -Uvh --root /path/to/your/root/partition ...

This isn't an rpm problem

Note You need to log in before you can comment on or make changes to this bug.