Bug 746684 - Sudo command has no effect
Sudo command has no effect
Status: CLOSED DUPLICATE of bug 745675
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-17 10:19 EDT by C. M. Trindade
Modified: 2011-10-17 16:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 16:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C. M. Trindade 2011-10-17 10:19:51 EDT
Description of problem:
After updating from Fedora 16 Beta to 3.1.0-0.rc9.git0.0.fc16.i686, the sudoers file has no effect on the user even when he is in the wheel group.

Version-Release number of selected component (if applicable):
sudo-1.8.1p2-2.fc16.i686

How reproducible:
Update to kernel 3.1.0-0.rc9.git0.0.fc16.i686 and run sudo command.

Steps to Reproduce:
1. open terminal in XFCE
2. run sudo command
3.
  
Actual results:
Prompts for password and then says "USER is not in the sudoers file".

Expected results:
root access

Additional info:
the wheel group has been enabled with visudo and the USER is in the wheel group in /etc/group file.
Comment 1 Mat Booth 2011-10-17 15:55:57 EDT
I am also suffering from this bug.

Installed F16 Beta from the DVD, updated to latest updates which included

kernel-3.1.0-0.rc9.git0.0.fc16.x86_64
sudo-1.8.1p2-2.fc16.x86_64

Now the sudo command no longer works for me. I am in the wheel group and the wheel group is in the sudoers file, but when sudo is invoked it tells me I am not in the sudoers file. I tried setting selinux to permissive mode, but that didn't make a difference.
Comment 2 Mat Booth 2011-10-17 16:01:56 EDT
Booting my previous kernel, kernel-3.1.0-0.rc6.git0.3.fc16.x86_64, has no effect either. :-/
Comment 3 Mat Booth 2011-10-17 16:16:18 EDT
In fact the version of sudo hasn't changed since I installed from the DVD, so something else has screwed it.

Anyone have any ideas what packages I could try downgrading?
Comment 4 Kevin Fenzi 2011-10-17 16:25:50 EDT
This looks like a dupe of 745675

*** This bug has been marked as a duplicate of bug 745675 ***

Note You need to log in before you can comment on or make changes to this bug.