This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 74671 - semaphore freeing problem
semaphore freeing problem
Status: CLOSED DUPLICATE of bug 74543
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-30 10:35 EDT by Need Real Name
Modified: 2014-01-21 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
comand line capture (3.21 KB, text/plain)
2002-09-30 10:37 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-09-30 10:35:29 EDT
Description of Problem:
Apache doesn't release two semaphores after each restart. If apache is 
restarted too many times all semaphores will be exhausted.

Version-Release number of selected component (if applicable):
apache-1.3.23-14

How Reproducible:

Steps to Reproduce:
1. ipcs
2. /etc/rc.d/init.d/httpd start
3. ipcs

Actual Results:
Two semaphores remain occupied after stopping apache.

Expected Results:
The semaphores should be released after apache is stoped

Additional Information:
kernel version 2.4.18-10
glibc 2.2.5-39
Comment 1 Need Real Name 2002-09-30 10:37:04 EDT
Created attachment 77704 [details]
comand line capture
Comment 2 Need Real Name 2002-10-01 04:14:46 EDT
It seems the problem is related to mod_ssl. After disabling ssl support in
httpd.conf the semaphores were freed upon stopping apache.
Comment 3 Need Real Name 2002-10-01 06:13:09 EDT
Previous comment not confirmed upon testing on a new machine. The problem 
persists upon disabling ssl.
Comment 4 Need Real Name 2002-10-01 06:40:48 EDT
After disabling mod_php4 in httpd.conf on several different machines, the 
problem was solved. So, it would seem the problem is related to mod_php 4.
Comment 5 Need Real Name 2002-10-01 07:58:19 EDT
After recompiling php without the option --with-mm, the problem disappeared. I 
am using mm-1.1.3-8 and mm-development-1.1.3-8.
Comment 6 Joe Orton 2003-01-16 12:55:39 EST

*** This bug has been marked as a duplicate of 74543 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:49:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.