Bug 74678 - Samba config bad when no interfaces present in service
Summary: Samba config bad when no interfaces present in service
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager   
(Show other bugs)
Version: 2.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-30 16:38 UTC by Lon Hohberger
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-30 16:40:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lon Hohberger 2002-09-30 16:38:29 UTC
Description of Problem:
When a service is created without at least one service IP address, SMB shares on
that service do not work.  This is because the default smb.conf.<sharename> is
generated with the expectation that at least one IP address in the service
configuration.

So, instead of the line:

        interfaces = 10.1.1.2/255.255.255.0

this is placed in the default smb.conf.<sharename>:

        interfaces = NULL

Version-Release number of selected component (if applicable): 1.0.11

How Reproducible: Always.


Steps to Reproduce: Add a service with no IP addresses and one disk device.  Be
sure to enable samba sharing.

Actual Results: Share does not work properly because nmbd does not start.

Expected Results: Clean start; working share.

Comment 1 Lon Hohberger 2002-09-30 16:40:25 UTC
This can be fixed one of two ways:

(1) Don't specify a Samba share without specifying an IP address.
(2) Remove the following line from smb.conf.<sharename>:

        interfaces = NULL

Cluadmin explicitly notes to modify the configuration file when it is first created.

Comment 2 Lon Hohberger 2002-11-12 13:43:42 UTC
Since this is a user/configuration error, I won't fix this unless it becomes a
real problem.



Note You need to log in before you can comment on or make changes to this bug.