Bug 746805 - RFE: Make deactivated items visible as deactivated
Summary: RFE: Make deactivated items visible as deactivated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2011-10-17 20:04 UTC by Sigbjorn Lie
Modified: 2012-06-20 13:15 UTC (History)
5 users (show)

Fixed In Version: ipa-2.2.0-1.el6
Doc Type: Enhancement
Doc Text:
Cause: Object which have enabled/disabled state (users, sudo, hbac rules, selinux policies) weren't distinguished in related search page in Web UI. Consequence: User didn't have quick overview of activated/deactivate objects. Change: Lines in search pages are greyed out and enabled column have different icon for each state. Result: User can easily distinguish enabled/disabled items in Web UI.
Clone Of:
Environment:
Last Closed: 2012-06-20 13:15:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0819 normal SHIPPED_LIVE ipa bug fix and enhancement update 2012-06-19 20:34:17 UTC

Description Sigbjorn Lie 2011-10-17 20:04:15 UTC
Description of problem:
This is a request to make deactivated user accounts/sudo rules/hbac rules visible and easy identifiable from the list they are in. For examply by an icon, or in a change in font color.

This will make it a lot easier to get an overview of disabled user accounts, and troubleshoot sudo and hbac rules, without having to enter every user and every rule.


Version-Release number of selected component (if applicable):
2.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Martin Kosek 2011-10-18 07:59:17 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/1996

Comment 3 Petr Vobornik 2012-02-01 15:12:39 UTC
Fixed in upstream.

 * 2a00393712eb490b23604399ea8318b3b4cca118

master:
 * fef343ae8f501aa67d4c746d9c7103d797fd6be2 
 * db4deb26f52a3104d31137e9689db4859b532cf9

ipa-2-2:
 * db4deb26f52a3104d31137e9689db4859b532cf9
 * 5b423e61b9813b6ce225beaabb00be2ba44d8bb4

Comment 5 Petr Vobornik 2012-04-24 12:04:45 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Object which have enabled/disabled state (users, sudo, hbac rules, selinux policies) weren't distinguished in related search page in Web UI.
Consequence: User didn't have quick overview of activated/deactivate objects. 
Change: Lines in search pages are greyed out and enabled column have different icon for each state.
Result: User can easily distinguish enabled/disabled items in Web UI.

Comment 6 Namita Soman 2012-05-03 13:51:38 UTC
verified using ipa-server-2.2.0-12.el6.x86_64

disabled user, hbac rules, and sudo rules are displayed in gray and enabled ones are in black

Comment 8 errata-xmlrpc 2012-06-20 13:15:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html


Note You need to log in before you can comment on or make changes to this bug.