Bug 74684 - XawTv dont do fullscreen
XawTv dont do fullscreen
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xawtv (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-30 14:26 EDT by vilou
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-06 07:47:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vilou 2002-09-30 14:26:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
when I press the "f" key to togge xawtv in fullscreen, the xawtv window simply
grow up to the size the screen but dont move.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. xawtv &
2. focus the xawtv window
3. press f

Actual Results:  The window grow up to the screen size but dont move.
The gnome-panels also stay on top. (baaad..)

Additional info:
Comment 1 Michael Schwendt 2002-09-30 19:17:51 EDT
With previous releases on had to load the video4linux X module in
/etc/X11/XF86Config:

    Load  "v4l"
Comment 2 vilou 2002-10-01 16:12:54 EDT
Adding the Load "v4l" in the XF86Config file doesnt change anything.. :(
Comment 3 Need Real Name 2002-10-13 22:36:36 EDT
I think the problem is with xawtv.
The version shipped with Redhat is 3.74.
According to the changelog at xawtv version 3.75 fixed the problem with
full-screen mode. Seems you need to update to 3.75 or higher to fix the
fullscreen problem.
http://bytesex.org/xawtv/changelog.html

FYI: I tried xawtv here on RH8.0 and I was able to verify the problem. Thing is
I am not crazy about xawtv. Got hooked on Zapping.http://zapping.sourceforge.net/
I have a ATI 8500DV card and zapping works great. And yes fullscreen works!
Also, avview from the Gatos project works in fullscreen for the 8500DV card.
I do not know what card you are using, but either update to a new version of
xawtv or go for zapping.

Greg - Just another Linux nut.
Comment 4 Michael Schwendt 2002-10-20 17:21:13 EDT
Interesting find. However, borderless full-screen works for me in Psyche as in
Valhalla, both without problems. Running KDE, though. Reporter uses GNOME.
Comment 5 Ranjit Solomon 2003-01-04 10:20:08 EST
Adding "v4l" to XF86Config modules fixed the problem
Comment 6 vilou 2003-01-04 14:00:33 EST
Adding the 'Load "v4l"' in the XF86Config doesnt change anything : 
http://livna.org/~anvil/Capture-v4l.png
However the bug is not always reproducible but the gnome panels always stay on top.
Comment 7 Dag Wieers 2003-01-04 16:44:37 EST
If you hit 'f' several times, the third time (second time it goes fullscreen) it
is positioned correctly as expected. 

The Gnome panel stays always on top though.

If it works, xawtv relocates the mouse-pointer to the top of the xawtv window,
but the Gnome panel is on top, so additional keypresses go to the Gnome panel.
Comment 8 Dag Wieers 2003-01-04 23:47:46 EST
It seems to be fixed in xawtv version 3.82. (Release 28 Dec 2002)
Both problems (fullscreen and hiding the Gnome panel).
The ChangeLog mentions wmhook fixes.

I have some packages build for RH 6.2, 7.3 and 8.0, at:

    ftp://dag.wieers.com/home-made/xawtv/

What's still a problem though, is that Gnome 2 doesn't allow to have
applications on top. Which probably is a Metacity bug (or missing feature). I
guess this bug can be closed now ?
Comment 9 Florin Andrei 2003-01-30 18:47:12 EST
For me, xawtv-3.82 didn't fixed the problem, but 3.83 did.
Using RH 8.0 with default Gnome/Metacity, GeForce2 and nVidia drivers.
Comment 10 Florin Andrei 2003-01-30 18:48:29 EST
Forgot to tell you, recent xawtv versions also trigger a bug in make on RH 8.0,
so i had to update that too.
Comment 11 Ngo Than 2003-03-06 07:47:14 EST
i have upgraded to 3.85, which will be available in next rawhide release.

Note You need to log in before you can comment on or make changes to this bug.