Bug 746857 - Returned 500 (Internal Server Error) with maven putuser
Returned 500 (Internal Server Error) with maven putuser
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
1.4.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 21:12 EDT by Ding-Yi Chen
Modified: 2012-04-23 00:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5-SNAPSHOT
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 00:32:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Client log (19.99 KB, text/plain)
2011-10-17 21:12 EDT, Ding-Yi Chen
no flags Details

  None (edit)
Description Ding-Yi Chen 2011-10-17 21:12:36 EDT
Created attachment 528677 [details]
Client log

Description of problem:
The server return 500 (Internal Server Error) when putuser with maven.


Version-Release number of selected component (if applicable):
Client 1.4.2-SNAPSHOT
Server Zanata version 1.4.2-SNAPSHOT (20111017-1543)


How reproducible:
Always

Steps to Reproduce:
1. Create a user "autotrans" with following command
mvn -e -U org.zanata:zanata-maven-plugin:putuser -Dzanata.url=http://zanata-endeavour.lab.eng.bne.redhat.com:8080/ -Dzanata.username=admin -Dzanata.key=b6d7044e9ee3b2447c28fb7c50d86d98 -Dzanata.userRoles=translator -Dzanata.userDisabled=false -Dzanata.userEmail=autotrans@zanata.com -Dzanata.userKey=23456789012345678901234567890123 -Dzanata.userLangs=ja,zh-Hans "-Dzanata.userName=Auto Translator" -Dzanata.userUsername=autotrans -Dzanata.userPasswordHash=UoT7kD9H6euhylD6H3oOPg==
  
Actual results:
Failed with 500 (Internal Server Error)

Expected results:
Successfully create the user "autotrans" without error.

Additional info:
Comment 1 Carlos Munoz 2012-01-05 19:15:25 EST
500 errors were being caused by a missing xml root element declaration on the Account class, and a null pointer exception when accessing an empty list on the same class. Both issues fixed and ready for validation.
Comment 3 Alex Eng 2012-01-05 20:35:15 EST
Verified in 1.5.

Note You need to log in before you can comment on or make changes to this bug.