Bug 746870 - Save as NeedReview should leave the cell editor open
Summary: Save as NeedReview should leave the cell editor open
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 1.4.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 1.4.2
Assignee: Alex Eng
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Depends On: 728854
Blocks: Zanata-1.4.2
TreeView+ depends on / blocked
 
Reported: 2011-10-18 04:13 UTC by Ding-Yi Chen
Modified: 2011-10-28 07:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 07:02:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 743157 None None None Never

Internal Links: 743157

Description Ding-Yi Chen 2011-10-18 04:13:24 UTC
Description of problem:
Some people use "Save as NeedReview" for save the unfinished work of lengthy translation, in this case, the cell editor should be left open.

However, current zanata instance immediately close the cell editor, this is not very convenient.

Version-Release number of selected component (if applicable):
Zanata version 1.4.2-SNAPSHOT (20111018-1316)

How reproducible:
Always

Steps to Reproduce:
1. Visit the message list view of any document, version, and project.
2. Type "hi" in row 1 translation.
3. Press Ctrl-S (Keyboard shortcut for Save as NeedReview"
  
Actual results:
Cell editor closed immediately.

Expected results:
Cell editor should remain open for further editing.

Comment 2 Ding-Yi Chen 2011-10-20 04:32:43 UTC
VERIFIED with Zanata version 1.4.2-SNAPSHOT (20111020-1402)

Comment 3 Runa Bhattacharjee 2011-10-21 09:42:55 UTC
The keyboard shortcut and the onscreen button for 'needs review' display different behaviour.

Ctrl+s - saves the unit as 'needs review' and keeps the focus on the cell for the user to continue typing

Flag button - saves the unit as 'needs review' but supresses the focus. The cell remains highlighted but not focused for editing. The user has to click once again inside the cell to get the cursor back.

Comment 5 Ding-Yi Chen 2011-10-24 06:50:16 UTC
With firefox-3.6.18 and firefox-3.6.20
The new version introduces that: pressing ctrl-s bring up Firefox's "Save Page as", instead of "Save as NeedReview".

The new version works well otherwise.

Thus this bug is re-ASSIGNED.

Comment 6 Sean Flanigan 2011-10-24 07:14:36 UTC
I can't reproduce that on firefox-3.6.18.  In any case, there's only so much we can do about shortcuts in the browser environment.  The house always wins.

If there's a lot of demand, we could try to find an alternative shortcut, but I'm not sure this feature will be used often enough to deserve it.  

As an alternative, you can press Tab twice, then Enter.

Comment 7 Alex Eng 2011-10-25 00:14:18 UTC
Need more info on how reproducible it is. Tested on Firefox 7 and Chrome, both works fine.

Comment 8 Ding-Yi Chen 2011-10-26 02:24:22 UTC
This is reproducible if you have enabled input method then press Ctrl-S.

Chrome works as expect, so does ibus-1.4/Firefox7/Fedora 16.

But Ctrl-S still invokes "Save As" popup with ibus-1.3.4, Firefox-3.6.18 (RHEL6) and scim-1.4.4, Firefox-3.6.20 (RHEL5).

I deem this bug as VERIFIED with Zanata version 1.4.2-SNAPSHOT (20111025-0954), yet I might put another bug if it's not ibus's bug.

Comment 9 Sean Flanigan 2011-10-26 03:15:42 UTC
The Ctrl-S shortcut is just a bonus.  If it works, great, if not the user has to use the mouse or press Tab-Tab-Enter.


Note You need to log in before you can comment on or make changes to this bug.