Bug 746956 - [RFE] WebUI interface for repo sync include / exclude lists
[RFE] WebUI interface for repo sync include / exclude lists
Status: CLOSED DUPLICATE of bug 1084522
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
1.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks: spacewalk-rfe
  Show dependency treegraph
 
Reported: 2011-10-18 07:57 EDT by Michael Mráka
Modified: 2014-05-22 07:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-22 07:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Mráka 2011-10-18 07:57:16 EDT
Description of problem:
spacewalk-repo-sync is able to filter packages from externa repo via --include/--exclude options.
There's also a database table rhnContentSourceFilter which can hold the include/excludeinformation for the repos but there's no way how to insert this filter lists from webUI.

Version-Release number of selected component (if applicable):
spacewalk-backend-1.6.33-1
spacewalk-schema-1.6.22-1
spacewalk-java-1.6.62-1

How reproducible:
always

Steps to Reproduce:
1. go to https://<spacewalk>/rhn/channels/manage/repos/RepoEdit.do?id=<xxx>
and try to specify include/exclude package lists for the repo
  
Actual results:
no way

Expected results:
there's a way ;)

Additional info:
Comment 2 Aron Parsons 2012-09-29 18:16:19 EDT
I've added the methods to support this on the backend as of spacewalk-java-1.8.152-1.  I also added API calls and an interface via spacecmd.  I'm not much of a web UI guy so I didn't do anything there, but I thought I'd let you guys know that the backend is there for this to implemented in the web UI now.
Comment 3 Dimitar Yordanov 2014-05-22 07:53:16 EDT

*** This bug has been marked as a duplicate of bug 1084522 ***

Note You need to log in before you can comment on or make changes to this bug.