Bug 74698 - Old patch is messing up sensors-detect
Old patch is messing up sensors-detect
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: lm_sensors (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-30 20:02 EDT by Michal Jaegermann
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-30 20:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-09-30 20:02:09 EDT
Description of Problem:

Spec file for lm_sensors applies the following

Patch4: lm_sensors-2.5.5-csb5.patch

to "add" a support for ServerWorks CSB5.  The problem is that for quite
a while this is already present in sensors-detect.  Here is the relevant
fragment of an unpatched Perl program:

     { 
       vendid => 0x1055,
       devid  => 0x9463,
       func => 0,
       procid => "SMSC Victory66 South Bridge",
       driver => "i2c-piix4",
       match => sub { $_[0] =~ /^SMBus PIIX4 adapter at / },
     } , 
     { 
       vendid => 0x1166,
       devid  => 0x0201,
       func => 0,
       procid => "ServerWorks CSB5 South Bridge",
       driver => "i2c-piix4",
       match => sub { $_[0] =~ /^SMBus PIIX4 adapter at / },
     } , 


Version-Release number of selected component (if applicable):
lm_sensors-2.6.3-2 but it is not like the first one with this problem
Comment 1 Phil Knirsch 2002-10-04 11:10:04 EDT
Yep, seen it now.

Removing patch from the package.

Thanks for noticing.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.