Bug 746982 - when I`m pressing the power button, the system turns off despite the settings of XFCE power manager
Summary: when I`m pressing the power button, the system turns off despite the settings...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: upower
Version: 17
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-18 13:30 UTC by Witek Mozga
Modified: 2013-04-14 17:06 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-14 17:06:24 UTC
Type: ---


Attachments (Terms of Use)
xfce4-power-manager.log (6.93 KB, text/plain)
2012-12-13 17:47 UTC, W Agtail
no flags Details

Description Witek Mozga 2011-10-18 13:30:13 UTC
Description of problem:

On my laptop, despite the settings of XFCE Power Manager (where I set 'ask' when power button is pressed), when I`m pressing the power button, the system turns off. 

Additional info:

I was told that the solution is here:
http://wiki.xfce.org/tips#handle_acpi_event_for_power_button_show_xfce_logout_options

Why isn`t that included in Fedora by default?

Comment 1 Kevin Fenzi 2011-10-18 14:56:41 UTC
Hum. It used to just work out of the box here on all my hardware. 

I can see it doesn't work right in f16 here. Will test on f15 hardware. 
When you press the power button do you hold it down for 5 seconds? Or just press quickly once?

Comment 2 Witek Mozga 2011-10-18 15:08:43 UTC
I just press quickly once. I tried to change the settings in xfce power manager but in vain.

Comment 3 Christoph Wickert 2011-10-19 17:57:37 UTC
(In reply to comment #0)
> Description of problem:
> 
> On my laptop, despite the settings of XFCE Power Manager (where I set 'ask'
> when power button is pressed), when I`m pressing the power button, the system
> turns off.

Please give us a little more background info:
- What kind of laptop is this?
- Is there another power manager running? Please give us the output of 'ps -A | grep power'
- What is the output of 
' xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/power-button-action'
- Can you reproduce the problem at the login manager?
- Can you reproduce the problem with another user?
- Can you reproduce it with the Xfce live CD?

> I was told that the solution is here:
> http://wiki.xfce.org/tips#handle_acpi_event_for_power_button_show_xfce_logout_options
> 
> Why isn`t that included in Fedora by default?

Because it doesn't really work properly:
- It doesn't work with multiple users logged in
- It requires acpid to be installed but we don't install it by default
- It cannot be configured graphically
- It won't fix your problem, this is for systems without xfce4-power-manager that downt turn off otherwise.

Comment 4 Witek Mozga 2011-10-19 18:14:47 UTC
ps -A | grep power
 1066 ?        00:00:00 upowerd
 1314 ?        00:00:00 xfce4-power-man

xfconf-query -c xfce4-power-manager -p xfce4-power-manager/power-button-action
gives 3

Comment 5 Witek Mozga 2011-10-19 18:55:04 UTC
I can reproduce this behaviour with another user account and at the login manager. I don`t have XFCE LiveCD. My laptop is a typical Asus A9RP.

Comment 6 Christoph Wickert 2011-10-19 19:18:26 UTC
(In reply to comment #4)
> ps -A | grep power
>  1066 ?        00:00:00 upowerd
>  1314 ?        00:00:00 xfce4-power-man

just like it should be

> xfconf-query -c xfce4-power-manager -p xfce4-power-manager/power-button-action
> gives 3

again, just like it should be.

(In reply to comment #5)
> I can reproduce this behaviour with another user account and at the login
> manager. 

OK, in this case it's no Xfce problem, because Xfce is not even loaded. gnome-power-manager is not installed, so the culprit must be udev/upower. Reassigning.

Comment 7 Witek Mozga 2011-10-25 09:16:59 UTC
I just tested Fedora 16 Beta and it still doesn`t work.

Comment 8 darton 2011-10-25 10:10:16 UTC
could this be related to https://bugzilla.redhat.com/show_bug.cgi?id=722325?

Comment 9 Witek Mozga 2011-10-25 10:33:25 UTC
d'Armany, you are probably right.

Comment 10 Witek Mozga 2012-06-02 14:28:56 UTC
Just installed Fedora 17 and still after I press power button, the system shuts down without asking

Comment 11 W Agtail 2012-12-03 13:56:01 UTC
Hi

When I initially installed F17 with XFCE, hitting the power button would shutdown. Some where along the lines of applying updates, the power button no longer shuts down my laptop which is a Lenovo Thinkpad E525.

All update are currently installed.

The following command returns 4:
xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/power-button-action

I have "When power button is pressed: Shutdown" selected within the Power Manager settings.

Any ideas?
Many thanks.

Comment 12 Kevin Fenzi 2012-12-04 00:00:23 UTC
What happens when you hit the power button?

Comment 13 W Agtail 2012-12-04 16:40:26 UTC
Hi, nothing at all happens when I hit the power button.
Kind Regards

Comment 14 Kevin Fenzi 2012-12-04 23:13:38 UTC
Could you provide the info christoph asked for in comment 3? Might help us isolate it.

Comment 15 W Agtail 2012-12-06 13:23:14 UTC
hi
from comment 3

Please give us a little more background info:
- What kind of laptop is this?
Lenovo ThinkPad E525

- Is there another power manager running? Please give us the output of 'ps -A | grep power'
ps -A | grep power
 1097 ?        00:00:00 upowerd
 1327 ?        00:00:00 xfce4-power-man
 1341 ?        00:00:00 xfce4-power-man

- What is the output of 
' xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/power-button-action'
4

- Can you reproduce the problem at the login manager?
from the login manager, hitting the power button causes the laptop to shutdown.

- Can you reproduce the problem with another user?
I created a new user called fred, and all works OK
The problem exists while logged in as user root

- Can you reproduce it with the Xfce live CD?
i don't have the CD to hand atm.

many thanks

Comment 16 Kevin Fenzi 2012-12-07 23:56:09 UTC
Can you stop xfce4-power-manager and run it in a terminal with: 

xfce4-power-manager --debug --no-daemon >& xfce4-power-manager.log

and press the power button and attach the log?

Comment 17 W Agtail 2012-12-13 17:47:07 UTC
Created attachment 663094 [details]
xfce4-power-manager.log

As requested, I have attached xfce4-power-manager.log. While tail -f xfce4-power-manager.log, no info was appended to this log file when I hit the power button. Thanks.

Comment 18 Aleksandar Kostadinov 2013-01-11 13:01:20 UTC
Not sure, but could it be like in fedora 18 where logind actually handles these events? See bug 886569.

Comment 19 Aleksandar Kostadinov 2013-01-11 13:04:22 UTC
Seems to me this is the case:

http://nottooamused.wordpress.com/2012/12/29/fedora-17-and-18-how-to-disable-auto-suspend-when-laptop-lid-is-closed/

I think this bug can be closed as notabug if somebody can confirm.

Comment 20 Kevin Fenzi 2013-01-11 17:21:16 UTC
I was going by the '17' in this report... :) 

Is this indeed a Fedora 17 install? Then that doesn't explain it. 

If it's Fedora 18, then indeed it would.

Comment 21 W Agtail 2013-04-14 16:03:03 UTC
Hi

FYI, I applied recent updates for F17 and all works OK.
I also installed F18 recently and all works OK with F18 too.
Thanks

Comment 22 Kevin Fenzi 2013-04-14 17:06:24 UTC
Great.


Note You need to log in before you can comment on or make changes to this bug.