Bug 746983 - rhn-channel traceback with abuse of service
Summary: rhn-channel traceback with abuse of service
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools   
(Show other bugs)
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Jiří Mikulka
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-18 13:34 UTC by Karel Volný
Modified: 2014-10-06 13:46 UTC (History)
5 users (show)

Fixed In Version: rhn-client-tools-1.0.0-76.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:59:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0752 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and enhancement update 2012-06-19 19:31:17 UTC

Description Karel Volný 2011-10-18 13:34:34 UTC
Description of problem:
If the system is banned, "rhn-check -l" throws traceback. I guess this could be handled more gracefully ...

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-39.el6.noarch

How reproducible:
(haven't tried, the ban ended)

Steps to Reproduce:
1. do something (?) nasty to get the system banned
2. rhn-channel -l
  
Actual results:
.qa.[root@ppcp-6s-0z-v1 tps]# rhn-channel -l
Traceback (most recent call last):
  File "/usr/sbin/rhn-channel", line 98, in <module>
    main()
  File "/usr/sbin/rhn-channel", line 86, in main
    channels = map(lambda x: x['label'], getChannels().channels())
  File "/usr/share/rhn/up2date_client/rhnChannel.py", line 99, in getChannels
    up2dateChannels = s.up2date.listChannels(up2dateAuth.getSystemId())
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 52, in __call__
    raise self.__exception_from_fault(f)
up2date_client.up2dateErrors.AbuseError: 
Error Message:
    Abuse of Service detected for server ppcp-6s-0z-v1.ss.eng.bos.redhat.com (1016580813)
Error Class Code: 49
Error Class Info: 
     You are getting this error because RHN has detected an abuse of
     service from this system and account. This error is triggered when
     your system makes too many connections to Red Hat Network. This
     error can not be triggered under a normal use of the Red Hat Network
     service as configured by default on Red Hat Linux.

     The Red Hat Network services for this system will remain disabled
     until you will reduce the RHN network traffic from your system to
     acceptable limits.

     Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt
     to contact technical support if you think you have received this
     message in error.



Expected results:
(the same error messages without the traceback at the beginning)

Additional info:

Comment 3 Jan Pazdziora 2011-11-24 14:40:07 UTC
Setting devel ack, to try to fix the issue.

Comment 5 Miroslav Suchý 2012-01-12 10:13:50 UTC
spacewalk.git d8936ff299f62b5821cb35d3e18b81291d75fbc7
cherrypicked to satellite.git as 429afd631728b60f4d620ed07164ab614b941881

Comment 9 errata-xmlrpc 2012-06-20 11:59:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0752.html


Note You need to log in before you can comment on or make changes to this bug.