This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 74713 - Ethernet modules don't load
Ethernet modules don't load
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-30 23:13 EDT by Stephen Rasku
Modified: 2013-07-02 22:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-25 14:38:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2002-09-30 23:13:49 EDT
Description of Problem:

I am trying to create a firewall using RH 7.3 and an old Pentium 90 but the
ethernet modules don't load even though the cards were detected properly during
install.

Version-Release number of selected component (if applicable):

Red Hat 7.3

How Reproducible:

100%

Steps to Reproduce:
1. Install Red Hat 7.3
2. Re-boot
3. modprobe ne2k-pci
4. modprobe via-rhine

Actual Results:

Upon booting, I get:

    ne2k-pci device does not seem to be present, delaying eth0 initialization

and:
 
    via-rhine device does not seem to be present, delaying eth1 initialization

The ethernet lines in /etc/modules.conf as created by the install are:

alias eth0 ne2k-pci
alias eth1 via-rhine

The results of "modprobe ne2k-pci" are:

/lib/modules/2.4.18-3/kernel/drivers/net/ne2k-pci.o: init_module: No such device
/lib/modules/2.4.18-3/kernel/drivers/net/ne2k-pci.o: insmod
/lib/modules/2.4.18-3/kernel/drivers/net/ne2k-pci.o failed
/lib/modules/2.4.18-3/kernel/drivers/net/ne2k-pci.o: insmod ne2k-pci failed
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters

The results of "modprobe via-rhine" are:

/lib/modules/2.4.18-3/kernel/drivers/net/via-rhine.o: init_module: No such device
/lib/modules/2.4.18-3/kernel/drivers/net/via-rhine.o: insmod
/lib/modules/2.4.18-3/kernel/drivers/net/via-rhine.o failed
/lib/modules/2.4.18-3/kernel/drivers/net/via-rhine.o: insmod via-rhine failed
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters

Expected Results:

The modules should be automatically loaded at boot-up and should be able to be
loaded manually.
Comment 1 Bill Nottingham 2002-09-30 23:21:15 EDT
Hm, sounds like a kernel issue.
Comment 2 Jeff Garzik 2002-10-25 13:51:39 EDT
Can you please provide "lspci" output?
Also, attempting to reproduce in 8.0 would be helpful.
Comment 3 Stephen Rasku 2002-10-25 14:38:19 EDT
I am sorry but I have changed that machine to OpenBSD.  Since it is working in
this configuration, I don't want to muck with it.  You might want to resolve
this WONTFIX.
Comment 4 Jeff Garzik 2002-10-25 14:43:25 EDT
ok, done :)

Thanks for responding so quickly.

Note You need to log in before you can comment on or make changes to this bug.