Bug 747193 - ICU does not support CCMP for Indic fonts
ICU does not support CCMP for Indic fonts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
15
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 543906
  Show dependency treegraph
 
Reported: 2011-10-19 00:26 EDT by Harshula Jayasuriya
Modified: 2012-01-23 16:56 EST (History)
5 users (show)

See Also:
Fixed In Version: icu-4.6-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 10:57:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ICU Indic CCMP testcase (9.63 KB, application/vnd.oasis.opendocument.text)
2012-01-04 22:54 EST, Harshula Jayasuriya
no flags Details
screenshot without fix (5.89 KB, image/png)
2012-01-04 22:56 EST, Harshula Jayasuriya
no flags Details
screenshot with fix (4.75 KB, image/png)
2012-01-04 22:56 EST, Harshula Jayasuriya
no flags Details

  None (edit)
Description Harshula Jayasuriya 2011-10-19 00:26:29 EDT
Description of problem:

Pango, Harfbuzz and Windows layout engine all appear to support CCMP for Indic.
However, ICU still does not. The ICU developers are under the incorrect
assumption that the Windows layout engine does not support CCMP for Indic.

So, in terms of CCMP support for Indic, it looks like we just need ICU fixed:
http://bugs.icu-project.org/trac/ticket/7601

For details and examples refer to the aforementioned ICU bug.
Comment 1 Caolan McNamara 2011-10-19 05:25:00 EDT
Do we think that Steven White's patch is what we want here ?, i.e.
http://bugs.icu-project.org/trac/attachment/ticket/7601/IndicReordering.cpp.diff
I can add that in on an experimental basis to rawhide if you want ?
Comment 2 Pravin Satpute 2011-10-19 05:40:43 EDT
Yes, it looks like.
Will be nice if can get rawhide build for test.
Comment 3 Harshula Jayasuriya 2011-10-19 09:14:41 EDT
(In reply to comment #1)
> Do we think that Steven White's patch is what we want here ?

Just double check that the bit mask does not conflict with an existing one. I vaguely remember something along those lines with his first patch.
Comment 4 Caolan McNamara 2011-10-19 11:30:55 EDT
yeah, bit mask is a dup of blwsFeatureMask
Comment 5 Caolan McNamara 2011-10-24 09:54:18 EDT
plausible tweak of the patch checked in, build blocked at the moment due to kernel/grubby nvr requires/provides problems
Comment 6 Caolan McNamara 2011-10-24 10:57:30 EDT
done as icu-4.8.1-2.fc17, wonder what side-effects it will have
Comment 7 Harshula Jayasuriya 2012-01-02 19:37:43 EST
Hi Caolan, if you could spin me a libicu package for F16, I'm more than happy to test it for you.
Comment 9 Caolan McNamara 2012-01-04 07:18:57 EST
ack, that's a 4.8.X, need a 4.6.X for F-16, bah
Comment 11 Harshula Jayasuriya 2012-01-04 22:54:56 EST
Created attachment 550804 [details]
ICU Indic CCMP testcase
Comment 12 Harshula Jayasuriya 2012-01-04 22:56:18 EST
Created attachment 550805 [details]
screenshot without fix
Comment 13 Harshula Jayasuriya 2012-01-04 22:56:56 EST
Created attachment 550806 [details]
screenshot with fix
Comment 14 Harshula Jayasuriya 2012-01-04 23:41:49 EST
The first row of the testcase file contains a sequence of Unicode Sinhala that tests FreeSerif's lookup that uses the CCMP feature.

Caolan, the RPM you built ensures that FreeSerif's lookup that uses CCMP works correctly. Thanks.

Do you plan on pushing an RPM with the fix into F16? F16 already has a -3 revision RPM, so the -2.1 revision RPM you built is older than what's available in the repository.
Comment 15 Fedora Update System 2012-01-05 05:35:58 EST
icu-4.6-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/icu-4.6-4.fc16
Comment 16 Fedora Update System 2012-01-23 16:56:34 EST
icu-4.6-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.