Bug 747225 - No default terminal command has been defined
No default terminal command has been defined
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 03:11 EDT by Robert Smol
Modified: 2013-02-13 06:46 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 06:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Smol 2011-10-19 03:11:51 EDT
Description of problem:
Modify keyboard settings, shortcut and set Alt-t to launch terminal. Close, pres Alt-t and adialog saying "No terminal command has been defined".

Version-Release number of selected component (if applicable):
Fedora 16 Beta

How reproducible:


Steps to Reproduce:
1. Launch Settings Keyboard
2. Modify shortcut for launching terminal to Alt-T
3. Pres Alt-T
  
Actual results:
Error dialog

Expected results:
Launching new instance of terminal

Additional info:
On the net I've found the fix it to run:
gconftool-2 --type=string --set "/desktop/gnome/applications/terminal/exec"      "gnome-terminal"

I am not sure if this is because of gconf/dconf changes
Comment 1 Arik Kfir 2011-11-04 21:14:49 EDT
The fix mentioned above works for me, 10x.
Comment 2 Matt Chan 2011-11-08 11:12:22 EST
I had the same problem on F16 release. The workaround was successful.
Comment 3 Matthias Clasen 2011-11-08 13:25:52 EST
The problem here might be that the default value for this key is stored in
/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas 
which belongs to libgnome.

Is libgnome installed on your system ?
Comment 4 Matt Chan 2011-11-08 13:40:58 EST
That might be it. Libgnome is not included by default from a livecd install?

Matt
Comment 5 bappman 2011-11-08 14:02:09 EST
I had this problem and didn't have libgnome installed. Problem solved after an install of libgnome.
Comment 6 laus 2011-11-11 06:31:17 EST
Had the same problem - installing libgnome did not help, but the workaround did
Comment 7 Andreas Loening 2011-11-17 22:10:48 EST
Had the same problem. I tried setting the /desktop/gnome/applications/terminal/exec gconf value, but that didn't fix it. Installing libgnome did fix it.
Comment 8 Fedora End Of Life 2013-01-16 06:59:42 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora End Of Life 2013-02-13 06:46:15 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.