Bug 747264 - Bluetooth not working in GNOME 3
Bluetooth not working in GNOME 3
Status: CLOSED DUPLICATE of bug 753617
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 06:15 EDT by Saurav Sengupta
Modified: 2011-11-17 21:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-13 14:19:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Saurav Sengupta 2011-10-19 06:15:01 EDT
Description of problem:
When Fedora 15 was released, the bluetooth service used to remain turned off by default so we had to explicitly enable it, which caused Bluetooth to work correctly. Now an ordinary software update corrects this and after updating all software on a clean installation of Fedora 15, the bluetooth service is already turned on. However, now trying to transfer files to a phone via Bluetooth in GNOME 3 no longer works. The system responds with the error message 'Connection refused (111)' every time. The computer also does not appear in the phone's list of detected devices and thus we cannot transfer files to the computer either. This may or may not be rectifiable by installing the gnome-user-share package but whereas earlier that package was installed by default and did not depend on the Apache Web server (httpd package), it now depends on httpd, which makes it problematic if there is no need for the Web sharing part and httpd.

Version-Release number of selected component (if applicable):
gnome-bluetooth-1:3.0.1-1.fc15 (x86_64)

How reproducible:
Try to perform file transfers (to/from) via Bluetooth in GNOME 3 on a clean installation of Fedora 15 on which all default software updates have been applied.

Steps to Reproduce:
1. Perform a clean (fresh) installation of Fedora 15 with GNOME 3.
2. Apply all software updates from the default channels.
3. Reboot the system.
4. Ensure that the bluetooth service is running.
5. Turn on Bluetooth on the computer and on a remote device such as a phone.
6. Using the 'Setup a New Device' option on the Bluetooth menu, pair the remote device with the computer.
7. Try to transfer files from the computer to the remote device.
8. Try to transfer files from the remote device to the computer.
  
Actual results:
In step 7, the computer responds with the error message 'Connection refused (111)' and the files are not transferred.
In step 8, the computer does not appear in the remote device's list of detected Bluetooth devices, so the files cannot be transferred.

Expected results:
In step 7, the files are transferred to the remote device without any error message.
In step 8, the computer appears in the remote device's list of detected Bluetooth devices, and selecting it allows the files to be transferred.

Additional info:
Since Bluetooth file transfer worked correctly when the bluetooth service used to be turned on manually, before the default software update was applied which turns on the bluetooth service automatically, this appears to be a regression, although it is doubtful that the problem is caused by the service being automatically turned on. Also, since gnome-user-share now depends on httpd, whereas previously (e.g., in Fedora 14) it did not do so, it has become undesirable to install it without consideration.
Comment 1 Saurav Sengupta 2011-10-23 14:38:28 EDT
I have verified this to be occurring on all GTK+ environments running Linux kernel 3.0.4 and above (2.6.40.x on Fedora 15) but I am unable to determine the exact component that is causing the problem. I have not checked on non-GTK+ environments.
Comment 2 James Heather 2011-11-09 03:37:56 EST
I wonder whether what I am seeing is part of the same issue.

My A2DP Bluetooth speakers (Pure-Fi Mobile) worked fine in F15. I used to turn the speakers on, they'd pair automatically, and then they'd appear as a sound device.

After the upgrade, when I turn the speakers on, they do pair properly; but the GNOME shell widget shows the connection to them as 'Off'. I can turn this on; but even after doing so, the speakers don't appear in any list of audio devices, so I can't get any sound coming out of them.

SELinux is set to permissive, so it's nothing to do with that.
Comment 3 Saurav Sengupta 2011-11-09 04:59:09 EST
(In reply to comment #2)
> I wonder whether what I am seeing is part of the same issue.
> 
> My A2DP Bluetooth speakers (Pure-Fi Mobile) worked fine in F15. I used to turn
> the speakers on, they'd pair automatically, and then they'd appear as a sound
> device.
> 
> After the upgrade, when I turn the speakers on, they do pair properly; but the
> GNOME shell widget shows the connection to them as 'Off'. I can turn this on;
> but even after doing so, the speakers don't appear in any list of audio
> devices, so I can't get any sound coming out of them.
> 
> SELinux is set to permissive, so it's nothing to do with that.

After which upgrade are you unable to use your speakers? Fedora 16? Did you upgrade from within Fedora 15 or did you install Fedora 16 independently, replacing Fedora 15?
Comment 4 James Heather 2011-11-09 05:37:00 EST
(In reply to comment #3)
> After which upgrade are you unable to use your speakers? Fedora 16? Did you
> upgrade from within Fedora 15 or did you install Fedora 16 independently,
> replacing Fedora 15?

This was an upgrade last night from a fully updated F15 system to F16, using preupgrade.

(I should add that sound works fine from the motherboard's built-in sound card through the analogue jack output.)
Comment 5 Saurav Sengupta 2011-11-09 06:42:44 EST
@James Heather: See if the bluez-hid2hci package is installed. If not, install it. Also, run the command su -c 'systemctl enable bluetooth.service' (requires root password). Restart your system and see if it works.
Comment 6 James Heather 2011-11-09 18:01:49 EST
(In reply to comment #5)
> @James Heather: See if the bluez-hid2hci package is installed. If not, install
> it. Also, run the command su -c 'systemctl enable bluetooth.service' (requires
> root password). Restart your system and see if it works.

Thanks, but that didn't solve it. The Bluetooth service was already enabled and started; the bluez-hid2hci package wasn't installed, but installing it (and rebooting) didn't make any difference. I can still pair the speakers, but they don't ever appear as an audio device.

The Bluetooth widget does know they're an audio device, though: it gives a "Pure-Fi Mobile" submenu, and one of the options under it is "Sound settings". (That takes me to the standard sound config dialog box, which doesn't have the speakers listed under "Hardware", though it used to under F15.)
Comment 7 Japplo 2011-11-10 17:03:35 EST
Hi, I have the same problem http://forums.fedoraforum.org/showthread.php?p=1527199#post1527199
/Japplo
Comment 8 Saurav Sengupta 2011-11-13 14:19:11 EST
Marking this bug as a duplicate of bug #753617 since this is not caused by GNOME 3.

*** This bug has been marked as a duplicate of bug 753617 ***
Comment 9 Adam Williamson 2011-11-17 21:21:39 EST
James: I think your bug is likely different, as Bluetooth audio streaming doesn't really have much to do with Bluetooth file transfer. It'd probably be best to file your issue separately.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.