Bug 74729 - xawtv video overlay problem with xinerama
xawtv video overlay problem with xinerama
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xawtv (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: FC3BugWeekTracker
  Show dependency treegraph
 
Reported: 2002-10-01 04:15 EDT by Ulrich Drepper
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 16:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2002-10-01 04:15:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020812

Description of problem:
When starting xawtv in my Xinerama-using enviornment the window frame and the
xawtv video overlay appear on different screen.  The offset on each screen is
identical, it's just that the two components use different screen.  xawtv seems
to be be somewhat xinerama awayre since it prints

xinerama 0: 1600x1200+1600+0
xinerama 1: 1600x1200+0+0

at startup.  But somewhere there is a little mistake,

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create Xinerama setup.  Screen 0 is at the right with a nonzero offset. 
Screen 1 has offset 0.
2.start xawtv
3.
	

Actual Results:  Window frame and contents on different screens.

Expected Results:  Window frame and contents on same screen.

Additional info:
Comment 1 Ngo Than 2003-03-06 15:18:55 EST
please try xawtv-3.85-1 in rawhide. Please let me know if it's fixed?
Comment 2 Dmitry Bolkhovityanov 2003-06-14 09:47:51 EDT
I've tried XawTv with Xinerama under RedHat9 (xawtv-3.81) today, and the problem
still exists.  3.85 and 3.88 from rawhide exibit the same "separated" behaviour.
Comment 3 Ulrich Drepper 2003-10-06 20:16:59 EDT
I do not have the same setup anymore.  I now use two separate video cards for
the two screens and in this setup xawtv works as expected.
Comment 4 Marcin Garski 2004-09-28 16:37:45 EDT
Thanks for the bug report. However, Red Hat no longer included xawtv
in Fedora Core. It has been replaced by tvtime.
Please upgrade to the latest version of Fedora Core and open a new bug
if the problem also occur in tvtime.

If you still use xawtv and this bug still persists, please report the
problem in upstream bug tracker or on mailing list
(usualy they can be found on xawtv website
http://linux.bytesex.org/xawtv/).
If the project don't have bug tracker and mailing list, you should
sent bug report by email to xawtv maintainer.
Also Fedora Legacy Project (http://fedoralegacy.org/) maintains some
older releases, and if you believe this bug is interesting to them,
please report the problem in the bug tracker at:
http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.