Bug 7473 - sndconf sets up opl3sax card incorrectly
sndconf sets up opl3sax card incorrectly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-01 05:48 EST by gerald
Modified: 2014-03-16 22:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 18:27:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gerald 1999-12-01 05:48:32 EST
I hava opl3-sax card by Yamah.
sndconfigure will automatically detect it and set everything up.
I can hear both samples (the au smaple could be a little louder!!!)
but after sndconfig exits I get an i/o conflict error from the midi
module and midi does not work. The reason is the following
incorrect /etc/conf.modules file:

alias sound opl3sa2
pre-install sound /sbin/insmod sound dmabuf=1
alias midi opl3
options opl3 io=0x388
options opl3sa2 mss_io=0x530 irq=5 dma=0 dma2=7 mpu_io=0x388 io=0x370
                                                         ^^^

If I change this according to "mpu_io=0x330", everything works fine
except for recording sound.
Comment 1 Bill Nottingham 1999-12-01 11:17:59 EST
Hm, that would be a bug. What's your isapnp.conf look like?
Comment 2 Bill Nottingham 2000-02-08 18:27:59 EST
Fixed in sndconfig-0.42-1, which will be in the next Raw Hide
release.

Note You need to log in before you can comment on or make changes to this bug.