Bug 747322 - NullPointerException in sun.awt.X11.XWindowPeer.restoreTransientFor
NullPointerException in sun.awt.X11.XWindowPeer.restoreTransientFor
Status: CLOSED DUPLICATE of bug 730015
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 09:50 EDT by Mary Ellen Foster
Modified: 2011-10-19 09:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-19 09:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 639306 None None None Never
Sun Bug Database 6826104 None None None Never

  None (edit)
Description Mary Ellen Foster 2011-10-19 09:50:44 EDT
Description of problem:
I'm seeing backtraces that start with the above error on Fedora 15. I'm using a fairly complex piece of software -- http://www.anvil-software.de/ -- and the error occurs when closing a modal dialogue box while trying to save.

This seems to be a bug that was recently fixed in Debian (I'll add the link shortly), with a fairly simple fix.


Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-59.1.10.3.fc15.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Try to save from Anvil
  
Actual results:
Exception occurred during event dispatching:
java.lang.NullPointerException
        at sun.awt.X11.XWindowPeer.restoreTransientFor(XWindowPeer.java:1681)
        at sun.awt.X11.XWindowPeer.removeFromTransientFors(XWindowPeer.java:1747)
        at sun.awt.X11.XWindowPeer.setModalBlocked(XWindowPeer.java:1469)
        at sun.awt.X11.XWindowPeer.setModalBlocked(XWindowPeer.java:1440)
        at java.awt.Window.setModalBlocked(Window.java:1359)
        at java.awt.Dialog.unblockWindow(Dialog.java:1597)
[ ... etc ...]
Comment 1 Deepak Bhole 2011-10-19 09:56:01 EDT

*** This bug has been marked as a duplicate of bug 730015 ***

Note You need to log in before you can comment on or make changes to this bug.