Bug 747334 - yppasswdd returns success when /etc/passwd.adjunct is not writable
yppasswdd returns success when /etc/passwd.adjunct is not writable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypserv (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Matej Mužila
Tomas Dolezal
Jiri Herrmann
: Patch
Depends On: 747317 747335
Blocks: 947782 1159825
  Show dependency treegraph
 
Reported: 2011-10-19 10:19 EDT by Honza Horak
Modified: 2016-05-31 07:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: ypserv-2.19-31.el6
Doc Type: Bug Fix
Doc Text:
*yppasswd* now correctly reports a failure of a user password change Prior to this update, when the *yppasswd* service failed to change the password of a *yppasswdd* user, it still reported a success. A test has been added to *yppasswdd* that verifies whether the write operation was successful. As a result, if *yppasswdd* fails to change a user password, an error message is now logged about it.
Story Points: ---
Clone Of: 747317
Environment:
Last Closed: 2016-05-10 16:33:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2011-10-19 10:19:44 EDT
+++ This bug was initially created as a clone of Bug #747317 +++

Description of problem:
If rpc.yppasswdd cannot write into /etc/passwd.adjunct (or /etc/shadow in standard configuration) because of wrong SELinux context, rpc.yppasswdd still reports success, which is wrong.

Version-Release number of selected component (if applicable):
ypserv-2.19-8.el5

How reproducible:
every-time

Steps to Reproduce:
1. change context of /etc/shadow or /etc/passwd.adjunct to wrong one
# chcon -t etc_t /etc/passwd.adjunct
2. try to change password of a user using yppasswd
3. /etc/passwd.adjunct is not updated and a message "Cannot create backup file /etc/passwd.adjunct.OLD: Permission denied" is logged into /var/log/messages
  
Actual results:
yppasswd returns success, so as rpc.yppasswdd in /var/log/messages

Expected results:
yppasswd returns failure, so as rpc.yppasswdd in /var/log/messages

--- Additional comment from hhorak@redhat.com on 2011-10-19 10:14:06 EDT ---

Created attachment 529012 [details]
proposed patch that reports failure when rename() fails
Comment 2 Suzanne Yeghiayan 2012-02-14 18:18:17 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 17 errata-xmlrpc 2016-05-10 16:33:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0793.html

Note You need to log in before you can comment on or make changes to this bug.