Bug 74734 - NTP server not verified?
NTP server not verified?
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 04:51 EDT by Ulrich Drepper
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 10:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2002-10-01 04:51:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020812

Description of problem:
I am not 100% sure that this really happens but I cannot explain what I see any
other way.

When selecting to use NTP in anaconda I selected one server down the list. 
Anaconda accepted it and wrote an appropriate ntp.conf file.  But when the
system was running the time went off.  From what I could see the server wasn't
responding at all.  In fact, the server never responded any time in the
following hours.  It seems that anaconda does not verify the server is usable by
looking at the ntpd status.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.During installation select one of the obscure NTP servers which don't work
2.
3.
	

Actual Results:  ntp doesn't work due to missing connection.

Expected Results:  anaconda should detect that the server isn't working
correctly and request another ntp server to be selected.

Additional info:
Comment 1 Michael Fulbright 2002-10-01 14:48:58 EDT
Anaconda does not support ntp configuration.

Reassigning to firstboot.
Comment 2 Henrik Brix Andersen 2002-10-05 05:16:35 EDT
I can reproduce this bug.
Comment 3 Kazutoshi Morioka 2002-10-13 09:58:12 EDT
New default ntp.conf has a line "restrict default ignore".
So, we need a "restrict" statement along with a "server" statement.
like this.

server my.ntp.example.com
restrict 192.168.1.1 mask 255.255.255.255 nomodify notrap noquery

But, firstboot dose not aware that.
Comment 4 Brent Fox 2002-10-15 10:12:21 EDT
aab36830, your post is referring to a different issue than was originally
reported.
Comment 5 Brent Fox 2002-10-15 10:22:22 EDT
redhat-config-date actually does attempt to make sure that the ntp server can be
contacted.  My guess is that the server was available when you ran
redhat-config-date and then later became unavailable.  

Also, I have previously tested all the servers to make sure that they work. 
Perhaps some have quit working since then.  I'm going to close as 'worksforme'.

Note You need to log in before you can comment on or make changes to this bug.