Bug 747375 - multiple occurrence of "+|-e" parameter is ignored
multiple occurrence of "+|-e" parameter is ignored
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lsof (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Schiffer
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 12:09 EDT by Branislav Náter
Modified: 2012-04-03 11:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 11:21:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Branislav Náter 2011-10-19 12:09:02 EDT
Description of problem:
It should be possible to call lsof with +|-e parameter to exclude kernel function calls (stat(), lstat(), readlink()) for particular filesystems. Multiple occurrence of this parameter is ignored.

Version-Release number of selected component (if applicable):
lsof-4.82-2.el6

How reproducible:
always

Steps to Reproduce:
two mounted filesystems are required (e.g. /boot, /home)
1. cd /boot
2. lsof -e /boot | grep /boot
3. lsof -e /home -e /boot | grep /boot
  
Actual results:
step 2.:
bash      2125      root  cwd   UNKNcwd            UNKNOWN                     /boot (-e /boot)
lsof      2551      root  cwd   UNKNcwd            UNKNOWN                     /boot (-e /boot)
grep      2552      root  cwd   UNKNcwd            UNKNOWN                     /boot (-e /boot)
lsof      2553      root  cwd   UNKNcwd            UNKNOWN                     /boot (-e /boot)

step 3.:
bash      2125      root  cwd       DIR                8,1     1024          2 /boot
lsof      2554      root  cwd       DIR                8,1     1024          2 /boot
grep      2555      root  cwd       DIR                8,1     1024          2 /boot
lsof      2556      root  cwd       DIR                8,1     1024          2 /boot

Expected results:
output from step 2. and 3. should be the same
Comment 5 errata-xmlrpc 2012-04-03 11:21:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0442.html

Note You need to log in before you can comment on or make changes to this bug.