Bug 747417 - anaconda is ignoring kickstart --fsprofile when combined with --useexisting or --onpart
anaconda is ignoring kickstart --fsprofile when combined with --useexisting o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-10-19 14:31 EDT by Chris Adams
Modified: 2011-11-02 21:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-16.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-02 21:51:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample kickstart (1.27 KB, application/octet-stream)
2011-10-19 14:31 EDT, Chris Adams
no flags Details

  None (edit)
Description Chris Adams 2011-10-19 14:31:42 EDT
Created attachment 529079 [details]
Sample kickstart

I'm attempting to set custom mke2fs options by adding a section to /etc/mke2fs.conf in %pre and using it via --fsprofile.  It appears that anaconda is ignoring the --fsprofile option though (this is with F16-Beta).

I'll attach a sample kickstart that shows the problem in a VM for me.
Comment 1 David Lehman 2011-10-19 15:08:33 EDT
Anaconda is erroneously ignoring fsprofile when combined with --useexisting or --onpart.
Comment 2 David Lehman 2011-10-19 15:44:48 EDT
An updates image is available for the time being which can be used with the version of anaconda in the Fedora 16 Beta. To use it, add the following to the boot command line:

  updates=http://dlehman.fedorapeople.org/updates-747417.0.img
Comment 3 David Lehman 2011-10-19 17:19:45 EDT
I'm proposing this as a NTH for F16 since the patch is very straightforward and low-risk.
Comment 4 Adam Williamson 2011-10-19 17:28:54 EDT
NTH is f16-accepted, not f16blocker.

+1 NTH, useful patch can't be fixed post-release, low risk.
Comment 5 Adam Williamson 2011-10-21 14:17:48 EDT
Discussed at 2011-10-21 NTH review meeting, accepted as NTH for the reasons mentioned in comment #4.
Comment 6 Fedora Update System 2011-10-25 17:02:23 EDT
anaconda-16.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.23-1.fc16
Comment 7 Adam Williamson 2011-11-02 21:51:33 EDT
This should be fixed now, let's close. Re-open if it's still happening in post-16.23 F16 RCs. thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.