Bug 74746 - FS Corruption with 2.4.18-10 (Athlon XP)
FS Corruption with 2.4.18-10 (Athlon XP)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 08:50 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 21:42:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-01 08:50:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
On an Athlon XP2000+ box I have been seeing severe filesystem corruption with the 2.4.18-10 (i686) kernel.

The box has:
00:00.0 Host bridge: VIA Technologies, Inc. VT8367 [KT266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8367 [KT266 AGP]
00:11.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)

The system disk is a 20GB Western Digital model code:
hda: WDC WD200EB-00CSF0, ATA DISK drive

The system worked stably with the original 2.4.18-3 kernel, but on upgrading to the -10 release (owing to nfs problems on other machines), initially it booted but then hung up. On trying to reboot it failed to boot (did not find the swap or root partitions) after grub had loaded the kernel. 

After a re-install and re-upgrade, it booted part way (hanging while looking for the NIS server) and rebooting to the rescue system revealed an unmountable root partion and fsck -y wiped the lot.

Initially I had an ext2 root partition, on the first re-install I changed to to ext3.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 2.4.18-10.i686 kernel to machine with stated hardware
2. Boot

 

Additional info:
Comment 1 Arjan van de Ven 2002-10-01 08:55:26 EDT
are there any kernel messages of value?
What kernel modules are you using?
Comment 2 Need Real Name 2002-10-01 09:12:42 EDT
Unfortunately any kernel message have been lost when I reinstalled. Since this 
is someone's workstation I'm loath to interrupt her work again to try to break 
it again. 
 
The currently loaded modules (with the 2.4.18-3 kernel) are: 
[root@lnxl root]# lsmod 
Module                  Size  Used by    Not tainted 
via82cxxx_audio        20480   0  (autoclean) 
uart401                 7936   0  (autoclean) [via82cxxx_audio] 
ac97_codec             11936   0  (autoclean) [via82cxxx_audio] 
sound                  71916   0  (autoclean) [via82cxxx_audio uart401] 
soundcore               6692   4  (autoclean) [via82cxxx_audio sound] 
binfmt_misc             7556   1 
nfs                    86172   3  (autoclean) 
lockd                  56768   1  (autoclean) [nfs] 
sunrpc                 75764   1  (autoclean) [nfs lockd] 
autofs                 12132   1  (autoclean) 
eepro100               20240   1 
ide-cd                 30272   0  (autoclean) 
cdrom                  32224   0  (autoclean) [ide-cd] 
usb-uhci               24452   0  (unused) 
usbcore                73216   1  [usb-uhci] 
ext3                   67136   5 
jbd                    49400   5  [ext3] 
Comment 3 Need Real Name 2002-10-01 11:01:54 EDT
OK: Just found a wierd message in the dmesg output for the current kernel   
which may be relevant:   
  
Uniform Multi-Platform E-IDE driver Revision: 6.31 
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx 
VP_IDE: IDE controller on PCI bus 00 dev 89 
PCI: No IRQ known for interrupt pin A of device 00:11.1. Please try using   
pci=biosirq.   
VP_IDE: chipset revision 6 
VP_IDE: not 100% native mode: will probe irqs later 
VP_IDE: Unknown VIA SouthBridge, contact Vojtech Pavlik <vojtech@suse.cz> 
 
Certainly something to do with the IDE controller.
Comment 4 Dave Jones 2003-12-16 21:42:24 EST
should be fixed in 2.4.20 errata kernels.

Note You need to log in before you can comment on or make changes to this bug.