Bug 747488 - nice not working
Summary: nice not working
Keywords:
Status: CLOSED DUPLICATE of bug 721416
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-20 02:57 UTC by Thawan Kooburat
Modified: 2011-12-18 01:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-18 01:53:33 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Thawan Kooburat 2011-10-20 02:57:39 UTC
Description of problem:
Setting nice value via "nice" command or setpriority() systemcall doesn't work. CPU-bound process with nice(+19) still consume CPU equal to user process with default nice value (presumably 0). 

Version-Release number of selected component (if applicable):
2.6.40.6-0.fc15.x86_64

How reproducible:
The same issue also occurred with the mainline kernel 3.0.7 on FC15.  However, the problem do not occur when I run kernel 2.6.32-71.el6.x86_64 on FC15

Steps to Reproduce:
1. Run 2 CPU-bound process but give one process with nice +19
2. 
3.
  
Actual results:
Observe that both of them still get equal amount of CPU time

Expected results:
In 2.6.32-71.el6.x86_64, process with nice +19 should get about 1.5% of CPU time

Additional info:

Comment 1 Thawan Kooburat 2011-12-18 01:53:33 UTC
Nice command is ignored due to "autogroup" feature

Disable autogroup at runtime or use "noautogroup" kernel boot option to disable it.

*** This bug has been marked as a duplicate of bug 721416 ***


Note You need to log in before you can comment on or make changes to this bug.