Bug 74752 - Provide proper, tested, firewall rules with each package
Provide proper, tested, firewall rules with each package
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.3
All Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 09:44 EDT by Bryce Nesbitt
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 15:36:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2002-10-01 09:44:00 EDT
It would be terribly nice if, when I install a package, that proper, tested,
firewall rules appear.

Packages like samba, imapd, netatalk & ntp all require firewall holes. 
Currently when I install those packages, they don't work.  They don't work
because the default RedHat install enables ipchains.

At the very least, how about a convention where the rpm adds these rules,
commented out, to /etc/sysconfig/ipchains?
Comment 1 Mike A. Harris 2002-10-09 02:58:25 EDT
Thanks for your suggestion.  This suggestion pertains more to the
distribution as a whole than to the ipchains package, so I'm
reassigning it to the distribution component for future
consideration.
Comment 2 Bill Nottingham 2005-03-01 15:36:31 EST
Closing bugs on older, no longer supported releases. Apologies for any lack of
response.

Note that system-config-securitylevel does have support for allowing some
protocols through.

Note You need to log in before you can comment on or make changes to this bug.