Bug 747542 - In echo "Loading Fedora (<version>)", the <version> is not updated when new kernels are installed
In echo "Loading Fedora (<version>)", the <version> is not updated when new k...
Status: CLOSED DUPLICATE of bug 732654
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 04:43 EDT by Jaroslav Franek
Modified: 2011-10-20 11:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 11:10:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Franek 2011-10-20 04:43:24 EDT
Description of problem:
After updating several times, I got three kernel versions installed. The grub menu is OK, but when I select the latest kernel to boot, the echo message still says I am booting the oldest kernel. This is false info, as the correct kernel is booted. I found it only a bit disturbing.

Copy and paste error when updating grub conf upon installation of a new kernel?


Version-Release number of selected component (if applicable):
grub2-1.99-10.fc16.x86_64

How reproducible:
Always. The mistake is encoded into /etc/grub2.conf, see below (note that I cut some irrelevant info, places noted by <cut...>):

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.1.0-0.rc10.git0.1.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
<cut...>
        echo 'Loading Fedora (3.1.0-0.rc8.git0.1.fc16.x86_64)'
        linux   /vmlinuz-3.1.0-0.rc10.git0.1.fc16.x86_64 
<cut...>
        echo 'Loading initial ramdisk ...'
        initrd /initramfs-3.1.0-0.rc10.git0.1.fc16.x86_64.img
}
menuentry 'Fedora (3.1.0-0.rc9.git0.0.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
<cut...>
        echo 'Loading Fedora (3.1.0-0.rc8.git0.1.fc16.x86_64)'
        linux   /vmlinuz-3.1.0-0.rc9.git0.0.fc16.x86_64<cut...>
<cut...>
        echo 'Loading initial ramdisk ...'
        initrd /initramfs-3.1.0-0.rc9.git0.0.fc16.x86_64.img
}
menuentry 'Fedora (3.1.0-0.rc8.git0.1.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
<cut...>
        echo 'Loading Fedora (3.1.0-0.rc8.git0.1.fc16.x86_64)'
        linux   /vmlinuz-3.1.0-0.rc8.git0.1.fc16.x86_64<cut...>
<cut...>
        echo 'Loading initial ramdisk ...'
        initrd /initramfs-3.1.0-0.rc8.git0.1.fc16.x86_64.img
}



Steps to Reproduce:
1. Install several kernel updates
2. Just boot the latest one (default)
3.
  
Actual results:
Booting Fedora (3.1.0-0.rc10.git0.1.fc16.x86_64), but the screen says
Loading Fedora (3.1.0-0.rc8.git0.1.fc16.x86_64)


Expected results:
The echo prints the correct version

Additional info:
Comment 1 Andre Robatino 2011-10-20 11:10:48 EDT

*** This bug has been marked as a duplicate of bug 732654 ***

Note You need to log in before you can comment on or make changes to this bug.