Bug 74759 - Intl keyboard AltGr key prints "0"
Intl keyboard AltGr key prints "0"
Status: CLOSED DUPLICATE of bug 71136
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-keyboard (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2002-10-01 10:22 EDT by Olivier Benghozi
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-21 09:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Olivier Benghozi 2002-10-01 10:22:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1) TextMode Login page: altgr key works OK.
2) After the login, under bash: AltGr key is fucked in all terminal: it works 
but it prints a 0 when you press it !
3) logoff. altgr key is still fucked in the login prompt and in all subsequent 
logins. If a password uses a character needing AltGr to be entered, your 
cannot login anymore.

Tested with French keyboard, and also with belgian keyboard configured.

Additional info: It was a bug in the null beta. It was not even assigned. Nor 
corrected of course. Of course it's still present.
Comment 1 David Martos 2002-10-02 09:21:24 EDT
The same is for Spanish keyboard after upgrading from redhat 7.3 to 8.0
Comment 2 Simon Matter 2002-10-03 01:59:35 EDT
Unfortunately I have created a bugreport about this for beta null just to learn
now that it is not fixed like several other bugs I reported.


This is going to be a true RedHat *.0 release :)
Comment 3 Nicolas Mailhot 2002-10-07 04:25:45 EDT
Same here, tested on 2 installs.
French extended keyboard (fr-latin-0)

Bug occurs when <num-lock> is activated (normal use for most extended keyboard
users), <alt-gr> prints a 0 before it can be used as a modifier.

So <altgr>+<6> should produce | but does 0| instead, and the console is now
unusable for most shell usage (same for <altgr>+<3> -> 0#, <altgr>+<0> -> 0@ and
so on)

(<altgr> in an *important* not optional i18n key, rxvt for example was rendered
useless for a lot of users when someone decided it would be a good idea to use
it as greek mode toggle)
Comment 4 Olivier Benghozi 2002-10-07 21:56:19 EDT
RedHat, we have a problem...
brosenkr@redhat.com, the one who is assigned this bug and all kbd bugs doesn't 
seem to read bugzilla. Nor to read his mail. Nor to work at RedHat. Nor to be 
alive. Nor to exist. In fact I have yet to see a post from him. He never 
responded anything (nor corrected anything) to any bugs assigned to him in 
the "null" beta (two monthes ago...)
It looks like we're in trouble to get those bugs fixed and this 8.0 just 
useable outside the US.
If somebody from RedHat can read this, please help ? :)
Comment 5 Simon Matter 2002-10-08 03:28:54 EDT
You're very right!

I posted several bugs for limbo and null and they are all not fixed yet.
1) Postfix, compiled with SASL2 support, but the wrong way. It just doesn't work
the way the packager expected it to work.
2) LDAP support in OpenOffice, it just doesn't work! When doing a 'network
install' of openoffice by hand, some files are missing needed for LDAP support.
I'm sure it could be
easily fixed but nobody looked at it building the RPM.
3) RPM hangs with locked database. I've been told it's fixed but, surprise
surprise, it
still happens in 8.0.
4) libpng upgrade for RedHat 6.2 doesn't work! It breaks many applications of

The funny part is that only when I asked for inclusion of XFS filesystem in
RedHat kernel, I got reply almost instantly and the bug was closed/deferred. At
least there were signs of life on the other side of bugzilla :)

Until RedHat points out good reasons to continue posting to bugzilla, I'll stop
waisting hours of time identifying and reporting bugs.
Comment 6 Gilles CHAUVIN 2002-10-20 17:27:18 EDT
RedHat Linux 7.3 upgraded to latest available kernel (2.4.18-17.7.x) using
up2date. Same problem (using fr-latin1 layout).
Comment 7 Nathaniel Case 2002-10-20 21:06:10 EDT
I see this problem using a US English keyboard.  In the console, pressing the
right ALT key prints a 0.  It didn't always do this, but once it reaches some
state it does this until I unplug the keyboard and plug it back in.

In X, this same problem makes it start printing "bbbbbbbbbbb" whenever I use
this key.  Pretty nasty..  this is occuring on this pretty typical Dell OptiPlex
system on RH 8.0, and it also occured in the (null) beta on my Athlon 750 system.
Comment 8 Nathaniel Case 2002-10-20 21:07:52 EDT
BTW, this bug is mis-categorized.  It's not really related to the
redhat-config-keyboard component.  Seems to be much lower level.
Comment 9 Olivier Benghozi 2002-10-21 07:57:49 EDT
I know it's slightly mis-categorized. This is a try to see someone at RedHat 
to tell something about the bug (correct it, maybe?). Before, the same bug was 
assigned to kbd package for several monthes (reported in the last beta) but if 
you read well, the kbd owner (brosenkr@redhat.com) never posted in bugzilla 
for several monthes (nor corrected any bugs) so he must be considered dead.
Comment 10 Christian Rose 2002-10-21 09:18:39 EDT
> the kbd owner (brosenkr@redhat.com) never posted in bugzilla
> for several monthes (nor corrected any bugs) so he must be considered dead.

He's not dead, but he no longer works for Red Hat.
Comment 11 Christian Rose 2002-10-21 09:22:38 EDT
Marking as a duplicate of bug 71136.

*** This bug has been marked as a duplicate of 71136 ***

Note You need to log in before you can comment on or make changes to this bug.