Bug 74762 - fdisk only handles partitions up to 16
fdisk only handles partitions up to 16
Status: CLOSED DUPLICATE of bug 56244
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 10:39 EDT by John McCarthy
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-01 10:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John McCarthy 2002-10-01 10:39:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
fdisk on a disk with partitions 1-22 only reports partitions up to #16.
It prints a Warning message that it is deleting partitons after 16.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.on a disk with >16 partitions run: fdisk /dev/hda
2.p
3.q
	

Actual Results:  [root@arthur root]# fdisk /dev/hda

The number of cylinders for this disk is set to 4866.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)
Warning: deleting partitions after 16

Command (m for help):  p

Disk /dev/hda: 255 heads, 63 sectors, 4866 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1       192   1542208+  1b  Hidden Win95 FAT32
/dev/hda2   *       193       323   1052257+   b  Win95 FAT32
/dev/hda3           324       491   1349460   1b  Hidden Win95 FAT32
/dev/hda4           492      4866  35142187+   f  Win95 Ext'd (LBA)
/dev/hda5           492       493     16033+  83  Linux
/dev/hda6           494       495     16033+  83  Linux
/dev/hda7           496       497     16033+  83  Linux
/dev/hda8           498       499     16033+  83  Linux
/dev/hda9           500       501     16033+  83  Linux
/dev/hda10          502       566    522081   82  Linux swap
/dev/hda11          567       697   1052226   83  Linux
/dev/hda12          698       893   1574338+  83  Linux
/dev/hda13          894      1612   5775336   83  Linux
/dev/hda14         1613      1638    208813+  83  Linux
/dev/hda15         1639      1657    152586   83  Linux
/dev/hda16         1658      1849   1542208+  83  Linux

Command (m for help): q



Expected Results:  I expect to see all partitions up to 22.  fdisk should be
able to deal with up to the max of 63 partitions supported by IDE disks (see hd
and fdisk man pages).

This works in sfdisk and parted:

[root@arthur root]# sfdisk -l /dev/hda

Disk /dev/hda: 4866 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls   #blocks   Id  System
/dev/hda1          0+    191     192-  1542208+  1b  Hidden Win95 FAT32
/dev/hda2   *    192     322     131   1052257+   b  Win95 FAT32
/dev/hda3        323     490     168   1349460   1b  Hidden Win95 FAT32
/dev/hda4        491    4865    4375  35142187+   f  Win95 Ext'd (LBA)
/dev/hda5        491+    492       2-    16033+  83  Linux
/dev/hda6        493+    494       2-    16033+  83  Linux
/dev/hda7        495+    496       2-    16033+  83  Linux
/dev/hda8        497+    498       2-    16033+  83 Linux
/dev/hda9        499+    500       2-    16033+  83  Linux
/dev/hda10       501+    565      65-   522081   82  Linux swap
/dev/hda11       566+    696     131-  1052226   83  Linux
/dev/hda12       697+    892     196-  1574338+  83  Linux
/dev/hda13       893+   1611     719-  5775336   83  Linux
/dev/hda14      1612+   1637      26-   208813+  83  Linux
/dev/hda15      1638+   1656      19-   152586   83  Linux
/dev/hda16      1657+   1848     192-  1542208+  83  Linux
/dev/hda17      1849+   2108     260-  2088418+  83  Linux
/dev/hda18      2393+   2846     454-  3646723+   b  Win95 FAT32
/dev/hda19      2847+   2977     131-  1052226    b  Win95 FAT32
/dev/hda20      2978+   3359     382-  3068383+   b  Win95 FAT32
/dev/hda21      3360+   3425      66-   530113+   b  Win95 FAT32
/dev/hda22      3426+   3426       1-     8001    1  FAT12

[root@arthur root]# parted /dev/hda print
Disk geometry for /dev/hda: 0.000-38172.750 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031   1506.093  primary   FAT         hidden
2       1506.094   2533.688  primary   FAT         boot
3       2533.689   3851.521  primary   FAT         hidden
4       3851.521  38170.063  extended              lba
5       3851.552   3867.209  logical   ext2        
6       3867.240   3882.897  logical   ext3        
7       3882.929   3898.586  logical   ext2        
8       3898.617   3914.274  logical   ext2        
9       3914.306   3929.963  logical   ext2        
10      3929.994   4439.838  logical   linux-swap  
11      4439.870   5467.434  logical   ext3        
12      5467.465   7004.904  logical   ext2        
13      7004.936  12644.912  logical   ext3        
14     12644.943  12848.862  logical   ext2        
15     12848.893  12997.902  logical   ext2        
16     12997.934  14503.996  logical   ext2        
17     14504.027  16543.498  logical   ext3        
18     18771.293  22332.546  logical   FAT         
19     22332.577  23360.141  logical   FAT         
20     23360.172  26356.640  logical   FAT         
21     26356.671  26874.360  logical   FAT         
22     26874.391  26882.204  logical   FAT         


Additional info:

I've modified /etc/makedev.d/linux-2.4.x so that MAKEDEV creates devices hda0-32
instead of the default of 0-16 and I've then run 'MAKEDEV hda' to create them. 
Otherwise you cannot mount or access the partitions.
See bug#74756 on this.

I haven't tried actually changing my partition table with this problem but I
assume if I write a modified partition table that fdisk will delete my
partitions 17-22.  This is not good.
Comment 1 Elliot Lee 2002-10-22 09:58:28 EDT

*** This bug has been marked as a duplicate of 56244 ***

Note You need to log in before you can comment on or make changes to this bug.