Bug 74763 - raid 5 drive fails to load on boot
raid 5 drive fails to load on boot
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 11:00 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 18:12:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-01 11:00:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
When booting with a raid 5 array the boot fails due to library dependancies.
output of ldd /sbin/mkraid
        libpopt.so.0 => /usr/lib/libpopt.so.0 (0x40027000)
        libc.so.6 => /lib/i686/libc.so.6 (0x4002e000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

/usr is not mounted when system loads raid.

Correct fix would be to use no dynamic libraries in /sbin or /bin
binaries.
The redhat fix will probly be move the popt package to /lib

Quick fix copy libpopt to /lib

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make a raid 5 array with persistant superblocks
2.reboot the system
3.Watch boot fail when it can't load the raid 5 array
	

Actual Results:  Boots into single user mode

Expected Results:  Boot into proper run level

Additional info:

All binaries in /bin and /sbin should be compiled staticly.

At very least all libraries needed by binaries in /bin and /sbin should
be in /lib.

Note You need to log in before you can comment on or make changes to this bug.