Bug 747630 - firstboot "Back/Forward" buttons can get pushed out of view in wordy languages
firstboot "Back/Forward" buttons can get pushed out of view in wordy languages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: John Sefler
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel62 750914
  Show dependency treegraph
 
Reported: 2011-10-20 10:46 EDT by John Sefler
Modified: 2013-01-10 05:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:26:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Back/Forward firstboot buttons getting pushed too far to the right (156.86 KB, image/png)
2011-10-20 10:46 EDT, John Sefler
no flags Details
fr_FR is broken in firstboot (141.32 KB, image/png)
2011-10-20 11:29 EDT, John Sefler
no flags Details
Back/Forward buttons are either missing or obscured (211.77 KB, image/png)
2011-10-20 15:01 EDT, John Sefler
no flags Details
fixed registration panel in fr_FR (140.62 KB, image/png)
2011-10-28 11:29 EDT, John Sefler
no flags Details
fixed registration panel in ja_JP (151.06 KB, image/png)
2011-10-28 11:29 EDT, John Sefler
no flags Details
fixed all subscriptions panel in ml_IN (this change applies to all langs) (228.89 KB, image/png)
2011-10-28 11:31 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-10-20 10:46:41 EDT
Created attachment 529302 [details]
Back/Forward firstboot buttons getting pushed too far to the right

Description of problem:
See the screenshot
When the "Entitlement Platform Registration" string is translated into a very long string in other languages (e.g. ja_JP), the Back/Forward firstboot buttons can conceivably be push entirely off the screen.

From the screenshot you can see that this affects all the "stretchable" gui control layout which is working as designed.  This can be problematic for the Back/Forward firstboot buttons because the user could get stuck on this firstboot panel with no where to go if these buttons get pushed too far to the right.

TODO: check all the supported languages to see if we are already broken.

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.96.16-1.el6.x86_64
subscription-manager-firstboot-0.96.16-1.el6.x86_64
subscription-manager-0.96.16-1.el6.x86_64


How reproducible:


Steps to Reproduce:
1.LANG=ja_JP.UTF8 firstboot --reconfig
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Sefler 2011-10-20 11:29:00 EDT
Created attachment 529328 [details]
fr_FR is broken in firstboot

Found that Forward firstboot button in LANG=fr_FR is off the screen.
Increasing the severity of this bug to High
Comment 2 John Sefler 2011-10-20 14:48:07 EDT
The long translation for "Entitlement Platform Registration" in firstboot affects these languages:

 fr_FR (affected the worst as shown in attachment 529328 [details])
 ja_JP
Comment 3 John Sefler 2011-10-20 15:01:04 EDT
Created attachment 529369 [details]
Back/Forward buttons are either missing or obscured

As shown in this screenshot, the next panel is similarly affected in these languages:

ml_IN  (worst case Forward is missing)
kn_IN  (worst case Forward is missing)
de_DE
es_ES
fr_FR
it_IT
ja_JP
pt_BR
ru_RU
or_IN
ta_IN
te_IN
Comment 4 James Bowes 2011-10-24 12:33:04 EDT
For the long translation of Entitlement Platform Registration, I've replaced the string with the translation for Entitlement Registration, but only for fr_FR and ja_JP (to minimize overall impact).

For the second issue, which is caused by our all subscriptions tab, I've split the date select and text filter gui parts to two lines, vs being on one long line as before.

Fixed in master, 6c9fdbd87b and
RHEL 6.2, b16ca87b3
Comment 6 John Sefler 2011-10-28 11:28:27 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.96.17-1.el6.x86_64
subscription-manager-0.96.17-1.el6.x86_64
subscription-manager-gnome-0.96.17-1.el6.x86_64

for l in fr_FR ja_JP en_US de_DE es_ES it_IT  ko_KR pt_BR ru_RU zh_CN zh_TW as_IN bn_IN hi_IN mr_IN gu_IN kn_IN ml_IN or_IN pa_IN ta_IN te_IN; do echo ""; echo ""; echo "# LANG=$l.UTF8 firstboot --reconfig"; LANG=$l.UTF8 firstboot --reconfig; done;

the following comments contain attached screenshots of the fixed languages (fr_FR, ja_JP on the registration page and ml_IN on the "All Available Subscriptions" tab showing the split line bewteen the date box and the text filter.
Comment 7 John Sefler 2011-10-28 11:29:14 EDT
Created attachment 530678 [details]
fixed registration panel in fr_FR
Comment 8 John Sefler 2011-10-28 11:29:43 EDT
Created attachment 530679 [details]
fixed registration panel in ja_JP
Comment 9 John Sefler 2011-10-28 11:31:45 EDT
Created attachment 530680 [details]
fixed all subscriptions panel in ml_IN  (this change applies to all langs)
Comment 10 errata-xmlrpc 2011-12-06 12:26:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.