Bug 747657 - Cannot restore saved domain
Cannot restore saved domain
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 12:13 EDT by Nicolas Corrarello
Modified: 2011-11-30 09:43 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 15:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Corrarello 2011-10-20 12:13:02 EDT
Description of problem:
After shutting down my laptop, libvirt saved the state of a VM. When trying to start it, it get the following

Error restoring domain: operation failed: failed to read qemu header

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 44, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 65, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1050, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 510, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: operation failed: failed to read qemu header

Since there is no way to manually remove that saved state, the virtual machine is rendered unusable.

Version-Release number of selected component (if applicable):
libvirt-0.9.6-2.fc16.x86_64


How reproducible:

Very
Steps to Reproduce:
1. Start a virtual machine
2. Power off host / power on host
3. Try to start virtual machien
  
Actual results:
Error message

Expected results:
Virtual Machine running

Additional info:
Comment 1 Laine Stump 2011-10-20 15:10:36 EDT
(In reply to comment #0)

> Since there is no way to manually remove that saved state, the virtual machine
> is rendered unusable.

This doesn't solve the basic problem, but there *is* a way to remove the saved state:

   virsh managedsave-remove $guestname

will get rid of it.
Comment 2 Nicolas Corrarello 2011-10-24 15:26:22 EDT
fixed in 

qemu-kvm-0.15.1-1.fc16.x86_64

virt-manager-0.9.0-6.fc16.noarch

libvirt-0.9.6-2.fc16.x86_64




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.