Bug 747662 - SELinux blocks block-backed disks used with Xen unless specially configured
Summary: SELinux blocks block-backed disks used with Xen unless specially configured
Status: CLOSED DUPLICATE of bug 745996
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: 16
Hardware: Unspecified Linux
unspecified
low
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-20 16:45 UTC by Kyle
Modified: 2011-10-22 11:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-22 11:34:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kyle 2011-10-20 16:45:19 UTC
Description of problem:
When starting a VM, Xen dies with "ERROR (XendBootloader:43) Disk isn't accessible" when using a block-backed disk and SELinux enforced

Version-Release number of selected component (if applicable):
F16 Beta

How reproducible:
Unknown. I'm going to try doing a fresh install of a VM tomorrow, see if that fixes it.

Steps to Reproduce:
1. Ensure SElinux is in enforcing mode
2. Start a VM (using xm create config.file or similar)
3. Watch it die
  
Actual results:
xm create prints an error ("Error: Disk isn't accessible") and dies

Expected results:
Xen VM comes up as per normal.

Additional info:
avc denial in dmesg:
[  887.378877] type=1400 audit(1319126448.379:25): avc:  denied  { read } for  pid=3168 comm="xend" name="dm-6" dev=devtmpfs ino=13634 scontext=system_u:system_r:xend_t:s0 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file

This VM was created with virt-install under F15, so SELinux labels should have been set correctly. 
Also, http://fedoraproject.org/wiki/FedoraXenQuickstartFC6#SELinux (FC6 is ancient, I know) says "Block device backed disks are already labelled correctly to allow them to pass SELinux checks." which no longer seems to be the case.

Comment 1 Kyle 2011-10-22 11:34:47 UTC

*** This bug has been marked as a duplicate of bug 745996 ***


Note You need to log in before you can comment on or make changes to this bug.