Bug 747866 - Printer (Dymo LabelWriter 400) doesn't install correctly
Summary: Printer (Dymo LabelWriter 400) doesn't install correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-21 08:07 UTC by Rolle
Modified: 2013-07-09 07:56 UTC (History)
9 users (show)

Fixed In Version: cups-1.6.2-12.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-02 00:34:07 UTC


Attachments (Terms of Use)

Description Rolle 2011-10-21 08:07:26 UTC
Description of problem:
I plugged in the LabelPrinter from Dymo "LabelWriter 400" and fedora installed the printerdriver automatically. But it doesn't print, cause I think it is the wrong driver. In Ubuntu 11.10 Live-CD I can add manually the LabelWriter and the also the same wrong driver is recommended. But I can choose a special dymo-driver and with this it worked perfectly.
The second disappointing case is. When I go to the printer settings I can't do a proper configuration of the printer. Nothing is editable. In the pre-gnome3-era I could manipulate the driver, the printing-area, resolution, ...
(in Ubuntu 11.10 this works well in the older style).

Version-Release number of selected component (if applicable):
Fedora 16 prerelease

How reproducible:
Every time

Steps to Reproduce:
1. Fedora 16 prerelease ightly build from 2011-10-19 installed on harddisk
2. made all updates until 2011-10-21
3. plug in Labelwriter and wait until the driver installs automatically
  
Actual results:
driver "Generic text-only printer" is automatically installed

Expected results:
A special dymo-driver seems the right driver. The labelWrite is a graphic-printer not only a text printer.

Additional info:
lsusb
Bus 004 Device 002: ID 0922:0019 Dymo-CoStar Corp.

Comment 1 Fedora End Of Life 2013-04-03 16:37:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Comment 2 Matthias Clasen 2013-05-31 04:02:48 UTC
Moving this to the printer driver side - we should find the right driver.

Comment 3 Tim Waugh 2013-05-31 11:42:49 UTC
Is this still a problem?  This report is quite old.

If you are still seeing this issue, please run this command with the printer connected and switched on. What output do you get?

su -c 'lpinfo -v'

Comment 4 Rolle 2013-06-14 11:18:34 UTC
Yes this problem still exists. The wrong driver (text driver) installs automatically. The "Dymo LabelWriter 400" is local connect with an USB-connection.
In Ubuntu 13.04 it is still the same wrong driver recommended, but I can select manually the right dymo-driver (gfx capable).
In Fedora 19 beta Nightly 2013-06-10 LiveCD (this test) I can't change the wrong driver.

So lpinfo -v outputs:

network socket
network lpd
network https
network ipps
network http
serial serial:/dev/ttyS0?baud=115200
network ipp
network smb
direct usb://DYMO/LabelWriter%20400?serial=07000216492455
network dnssd://HP%20LaserJet%20P2015%20Series%20(108DA7)._pdl-datastream._tcp.local/


Thanks Rolle

Comment 5 Tim Waugh 2013-06-14 11:43:45 UTC
Thanks.  What about 'lpinfo -l -v'?

Comment 6 Rolle 2013-06-14 13:55:13 UTC
lpinfo -l -v

Device: uri = http
        class = network
        info = Internet Printing Protocol (http)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = lpd
        class = network
        info = LPD/LPR Host or Printer
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = ipp
        class = network
        info = Internet Printing Protocol (ipp)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = serial:/dev/ttyS0?baud=115200
        class = serial
        info = Serial Port #1
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = https
        class = network
        info = Internet Printing Protocol (https)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = ipps
        class = network
        info = Internet Printing Protocol (ipps)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = usb://DYMO/LabelWriter%20400?serial=07000216492455
        class = direct
        info = DYMO LabelWriter 400
        make-and-model = DYMO LabelWriter 400
        device-id = MFG:DYMO;CMD: ;MDL:LabelWriter 400;CLASS:PRINTER;DESCRIPTION:DYMO LabelWriter 400;SERN:07000216492455;
        location = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 
        location =

Comment 7 Tim Waugh 2013-06-14 14:04:32 UTC
You can choose which driver to use by using the 'system-config-printer' application, which appears as "Print Settings" in the application list in GNOME.

Which driver is correct for this device?

Comment 8 Rolle 2013-06-14 19:18:29 UTC
Now I installed the Fedora 19 beta and updated to the latest packages 2013-06-14 (Kernel 3.9.5, CUPS 1.6.2). After the automatically installation of the wrong text driver I see I can click on the "modell"-field "text only driver" and can change the driver to "Dymo Label Printer". This is only possible then I UNLOCKED the settings. So this manually change works. But I think this unvisible button will many user overseen. So now this works. Fine.

The other problem that the automatism installs the wrong driver must be fixed. The right driver is "Dymo/Dymo Label Printer". And this one works fine.

Thank you Tim.

Comment 9 Tim Waugh 2013-06-21 10:56:08 UTC
This driver is actually provided by CUPS itself.  Should be fixed in cups-1.6.2-10.fc19.

Comment 10 Fedora Update System 2013-06-26 15:14:54 UTC
cups-1.6.2-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cups-1.6.2-12.fc19

Comment 11 Fedora Update System 2013-06-26 17:04:22 UTC
Package cups-1.6.2-12.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.6.2-12.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11691/cups-1.6.2-12.fc19
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2013-07-02 00:34:07 UTC
cups-1.6.2-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Rolle 2013-07-09 07:56:03 UTC
Works perfectly.
In Fedora 19 Final Release (DVD ISO, 2013-07-02) is yet the older cups package. But then I updated on 2013-07-05 the new cups package is here. Now I can plug in the "Dymo LabelWriter 400" and the printer is automatically recognized and the right graphics-capable driver is automatically installed.

Thank you Tim.


Note You need to log in before you can comment on or make changes to this bug.