This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 747898 - 'Enter' and 'Ctrl+Enter' keyboard shortcuts do not shift focus if 'Next Entry' is chosen in the navigation settings
'Enter' and 'Ctrl+Enter' keyboard shortcuts do not shift focus if 'Next Entry...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.4.2
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks: Zanata-1.4.2 748696
  Show dependency treegraph
 
Reported: 2011-10-21 06:33 EDT by Runa Bhattacharjee
Modified: 2013-03-03 21:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:02:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Runa Bhattacharjee 2011-10-21 06:33:33 EDT
Description of problem:

In the newly added settings for navigation, selecting the last item in the drop down 'next entry' partially disables the 'Enter' (if selected) and 'Ctrl+Enter' keyboard shortcuts. These shortcuts allow the users to save the current entry and to move to the next entry. However, in this case the current entry gets saved, but the focus remains on the cell when 'Enter' (if selected) or 'Ctrl+Enter' is used.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Login to Zanata and navigate to a project of your choice. Open a file in the web editor

2. Using the settings icon on the navigation panel, select 'Enter' key saves immediately' and 'Navigation key/button options:'=>'Next Entry'

3. Start editing an entry and click 'Enter' or 'Ctrl+Enter' to save that entry. 
  
Actual results:

The entry is saved, but the focus remains on the entry

Expected results:

The entry is saved and the focus moves to the next entry

Additional info:

Ideally the 'Next Entry' option should not be present in the dropdown. It already has an exclusive button on the navigation panel.
Comment 1 Ding-Yi Chen 2011-10-23 20:06:43 EDT
This behaviour is observed with Zanata version 1.4.2-SNAPSHOT (20111021-1207)
Comment 2 Sean Flanigan 2011-10-23 22:44:06 EDT
The reason "Next Entry" is in the dropdown is so that Enter/Ctrl-Enter can support the new modal navigation feature and still have the ability to go simply to the next row.  But obviously you've found a bug with that.  

But even if that feature were working, it doesn't seem to be well liked, so we can just take it out of the dropdown, and Enter/Ctrl-Enter will just go to the next row, as before.
Comment 3 Alex Eng 2011-10-24 00:38:02 EDT
Remove 'Next Entry' option from shortcut config. 
CTRL+Enter / Enter in editor move to next entry.

Fix bug:
https://github.com/zanata/zanata/commit/93783eb1f946be35c8ad65f2f6dc608b4df8ddff
Comment 4 Ding-Yi Chen 2011-10-24 02:56:37 EDT
With Zanata version 1.4.2-SNAPSHOT (20111024-1450)

As expected:
The 'Next Entry' is removed.
Ctrl-Enter/ (Enter) moved to next entry.

However, now Ctrl-Enter /Enter does not change the NeedReview entries to Approved.

Thus, this bug is re-ASSIGNED.
Comment 6 Ding-Yi Chen 2011-10-25 23:43:51 EDT
VERIFIED with Zanata version 1.4.2-SNAPSHOT (20111025-0954)

Note You need to log in before you can comment on or make changes to this bug.