Bug 747920 - Machine is unbootable after F15-F16 upgrade
Machine is unbootable after F15-F16 upgrade
Status: CLOSED DUPLICATE of bug 737731
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-21 07:58 EDT by Need Real Name
Modified: 2011-10-21 12:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 12:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2011-10-21 07:58:44 EDT
Description of problem:
After upgrading from F15 to F16 beta my machine is unbootable.

Version-Release number of selected component (if applicable):
anaconda-16.22-1.fc16.x86_64

How reproducible:
Every time. Same problem on both machines

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Bootable operating system.

Expected results:
Unbootable.

Additional info:
There is no new kernel entry in the grub config.

# grep grub upgrade.log
12:05:49 Upgrading grubby-8.3-1.fc16.x86_64
grubby fatal error: unable to find a suitable template
12:27:09 Upgrading grub2-1.99-9.fc16.x86_64
12:36:22 Upgrading grub-efi-0.97-83.fc16.x86_64
grubby fatal error: unable to find a suitable template
grubby: doing this would leave no kernel entries. Not writing out new config.
grubby fatal error: unable to find a suitable template
grubby: doing this would leave no kernel entries. Not writing out new config.
grubby fatal error: unable to find a suitable template
grubby: doing this would leave no kernel entries. Not writing out new config.

Please also see bug 728301.
Comment 1 Need Real Name 2011-10-21 08:00:43 EDT
Might be a problem with grubby. I don't know what writes the template that is missing.
Comment 2 Adam Williamson 2011-10-21 11:58:39 EDT
Which option did you choose at the bootloader upgrade screen: "new bootloader configuration" or "skip bootloader configuration"?
Comment 3 Adam Williamson 2011-10-21 11:59:30 EDT
Please attach the full logs. Those errors from grubby aren't actually necessarily as fatal as they seem (you get the same errors when you do a yum upgrade from f15 to f16 and then update the kernel, but grub config actually gets updated correctly).
Comment 4 Need Real Name 2011-10-21 12:28:14 EDT
I didn't choose any bootloader option, it was an automated upgrade using preupgrade.

Bug 741538 has logs from an install of another machine with the same problem.
Comment 5 Adam Williamson 2011-10-21 12:30:35 EDT
ah. if you used preupgrade then this is https://bugzilla.redhat.com/show_bug.cgi?id=737731 . There's now an updated F15 build of preupgrade:

https://admin.fedoraproject.org/updates/preupgrade-1.1.10-1.fc15

which should have this fixed. Please re-test with that.

*** This bug has been marked as a duplicate of bug 737731 ***

Note You need to log in before you can comment on or make changes to this bug.