Bug 747939 - bodhi -r dist-f14 -b 676195 don't respect -r option
bodhi -r dist-f14 -b 676195 don't respect -r option
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
16
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-21 09:03 EDT by Nikola Pajkovsky
Modified: 2016-09-19 22:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 16:18:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola Pajkovsky 2011-10-21 09:03:41 EDT
Description of problem:
bodhi client or better bodhi server returns wrong answer. When you try to ask for bodhi server: "give me all builds which fix bug XYZ for fedora 14" it w/o any problems returns build for f15 (any builds which fix the bug).

Version-Release number of selected component (if applicable):


How reproducible:
$ bodhi -r dist-f14 -b 676195
  
Actual results:
$ bodhi -r dist-f14 -b 676195
 griffith-0.12.1-2.fc14                       enhancement  stable    2011-03-23 
 griffith-0.12.1-2.fc15                       enhancement  stable    2011-03-24 


Expected results:
$ bodhi -r dist-f14 -b 676195
 griffith-0.12.1-2.fc14                       enhancement  stable    2011-03-23 

Additional info:
I will write a workaround to filter out wrongly returned builds, but it's problem on the server side.

I'm putting bug as *urgent*, because I'm trying to put it into abrt/libreport to be able find builds before abrt tries to creates new ticket in bugzilla
Comment 1 Luke Macken 2011-10-21 14:31:40 EDT
On it...
Comment 2 Luke Macken 2011-10-21 15:01:27 EDT
I got `bodhi -r <release> -b <bug>` queries working in:

    https://fedorahosted.org/bodhi/changeset/be8c4dd325fffa5f026b50f60f07a46254abf4a7

Also, bodhi never supported querying releases by their dist-tags, like your example shows, so I added it in:

    https://fedorahosted.org/bodhi/changeset/2ac4fdf754f19987fe45c3e671d5c99e22c2e166

I'll try and deploy this to production today.
Comment 3 Nikola Pajkovsky 2011-10-24 05:27:36 EDT
thanks for nice and quick job!
Comment 4 Luke Macken 2011-10-24 16:18:13 EDT
These patches are now in production!
Comment 5 Nikola Pajkovsky 2011-10-25 05:12:40 EDT
and works like charm, thanks
Comment 6 Luke Macken 2012-07-20 14:19:14 EDT
This particular ServerError has been fixed in the bodhi-server for quite some time now. I also just verified that fedora-easy-karma works as expected on RHEL5.

Note You need to log in before you can comment on or make changes to this bug.