Bug 74795 - When not installing the KDE desktop, QT/KDE apps doesnt use Bluecurve
Summary: When not installing the KDE desktop, QT/KDE apps doesnt use Bluecurve
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
: 80103 (view as bug list)
Depends On:
Blocks: 67217 79578
TreeView+ depends on / blocked
 
Reported: 2002-10-01 19:08 UTC by Kenneth Rohde Christiansen
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 00:02:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kenneth Rohde Christiansen 2002-10-01 19:08:48 UTC
Description of problem:
It seems that the KDE/QT Bluecurve theme is applied when logging into KDE for
the first time. This means when not installing the KDE desktop, and only a few
KDE apps, these apps will not use Bluecurve as default theme 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install Red Hat 8.0 without KDE Desktop
	

Additional info:

Comment 1 Havoc Pennington 2002-10-01 19:28:31 UTC
Gack! This never got fixed? This was really, really supposed to be fixed, I
thought it was marked blocker and then closed.

Comment 2 Ngo Than 2002-10-07 10:55:25 UTC
you still have old qt/kde settings in your home. You have to remove ~/.qt and
~/.kde/share/config/kdeglobals.



Comment 3 Kenneth Rohde Christiansen 2002-10-07 11:05:43 UTC
Definately NOT. This was no upgrade, and I didnt reuse my home/ dir. This was a
new installation on my new labtop. I have seen this bug on two other computers
aswell. Consider to reopen the bug.

Comment 4 Ngo Than 2002-10-08 20:34:03 UTC
could please send your /usr/lib/qt-3.0.5/etc/settings/qtrc and ~/.qt/qtrc.
I think somehing is wrong here.


Comment 5 Ngo Than 2003-02-03 13:41:44 UTC
*** Bug 80103 has been marked as a duplicate of this bug. ***

Comment 6 Owen Taylor 2003-02-03 21:12:50 UTC
With the current packages, I'm not getting the right Qt theme even
when I _do_ log into KDE, and log out, then log into GNOME.

~/.qt/qtrc contains style=keramik, which is overriding the 
/usr/lib/qt-[VERSION]/etc/settings/qtrc value of Bluecurve.

Comment 7 Havoc Pennington 2003-02-03 21:18:21 UTC
Taking out of NEEDINFO since owen posted qtrc contents that seem to explain the
problem.

Comment 8 Ngo Than 2003-02-07 00:02:30 UTC
it's a bug in kdelibs and is fixed in kdelibs-3.1-3.



Note You need to log in before you can comment on or make changes to this bug.